Project

General

Profile

action #40409

[functional][fast][u] test fails in keyboard_layout_gnome

Added by dimstar about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-08-29
Due date:
2018-09-11
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_on_gnome@64bit fails in
keyboard_layout_gnome

Acceptance Criteria

AC1: Test works as expected on o3

Suggestions

  • Try to reproduce locally
  • crosscheck why it worked in dheidlers verification run, but not on o3

Reproducible

Fails since (at least) Build 20180813

Expected result

Last good: 20180812 (or more recent)

Further details

Always latest result in this scenario: latest

This is a new test module added by https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5636
Since it's addition, there was no successful run of this module for openSUSE TUmbleweed

History

#1 Updated by mgriessmeier about 3 years ago

  • Subject changed from test fails in keyboard_layout_gnome to [functional][fast][u] test fails in keyboard_layout_gnome
  • Due date set to 2018-09-11
  • Assignee deleted (asmorodskyi)

#2 Updated by mgriessmeier about 3 years ago

  • Description updated (diff)
  • Status changed from New to In Progress

#3 Updated by mgriessmeier about 3 years ago

  • Status changed from In Progress to Workable

#4 Updated by nicksinger about 3 years ago

  • Assignee set to nicksinger

#5 Updated by nicksinger about 3 years ago

  • Status changed from Workable to In Progress

#6 Updated by nicksinger about 3 years ago

I was able to reproduce this on a fresh and recent openQA version: http://openqa.chell.qa.suse.de/tests/20
So my current suspicion is that some update (e.g. qemu or os-autoinst) changed the behavior.

Also one of the proceeding fails in network-manager comes from this changed layout ("u gets translated into ΓΌ)

#7 Updated by nicksinger about 3 years ago

  • Status changed from In Progress to Resolved

I've created a suggestion to fix this specific issue in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5701
However since this test has several problems anyway, we reverted it for now: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5702

#8 Updated by dheidler about 3 years ago

New PR that includes Nicks changes (as well as some fix to preserve the keyboard layout check for the console):
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5755

Also available in: Atom PDF