action #40352

Unexpected end of data from the backend

Added by szarate over 1 year ago. Updated 9 months ago.

Status:RejectedStart date:28/08/2018
Priority:NormalDue date:
Assignee:okurz% Done:

0%

Category:Concrete Bugs
Target version:Done
Difficulty:
Duration:

Description

Observation

There's a message from the qemu backend implying that process (perl) might have died, I think I have seen this one few times already...

[2018-08-27T15:20:22.0131 UTC] [debug] no match: 295.5s
[2018-08-27T15:20:22.0162 UTC] [debug] QEMU: qemu-system-aarch64: terminating on signal 15 from pid 40747 (perl)
[2018-08-27T15:20:22.0172 UTC] [debug] sending magic and exit
[2018-08-27T15:20:22.0172 UTC] [debug] received magic close
[2018-08-27T15:20:22.0219 UTC] [debug] backend process exited: 0
Unexpected end of data 0
[2018-08-27T15:20:22.0356 UTC] [debug] Driver backend collected unknown process with pid 24125 and exit status: 1
[2018-08-27T15:20:23.0359 UTC] [error] can_read received kill signal at /usr/lib/os-autoinst/myjsonrpc.pm line 89.

[2018-08-27T15:20:23.0388 UTC] [debug] commands process exited: 0
[2018-08-27T15:20:24.0388 UTC] [debug] sysread failed: 
[2018-08-27T15:20:24.0395 UTC] [debug] syswrite failed Broken pipe at /usr/lib/os-autoinst/myjsonrpc.pm line 38.
    myjsonrpc::send_json('GLOB(0x144a8b38)', 'HASH(0x118dd620)') called at /usr/lib/os-autoinst/autotest.pm line 282
    autotest::query_isotovideo('backend_last_screenshot_data') called at /usr/lib/os-autoinst/basetest.pm line 498
    basetest::_result_add_screenshot('patch_sle=HASH(0x14264b40)', 'HASH(0x147fdd80)') called at /usr/lib/os-autoinst/basetest.pm line 350
    basetest::runtest('patch_sle=HASH(0x14264b40)') called at /usr/lib/os-autoinst/autotest.pm line 328
    eval {...} called at /usr/lib/os-autoinst/autotest.pm line 327
    autotest::runalltests() called at /usr/lib/os-autoinst/autotest.pm line 183
    eval {...} called at /usr/lib/os-autoinst/autotest.pm line 183
    autotest::run_all() called at /usr/lib/os-autoinst/autotest.pm line 236
    autotest::__ANON__('Mojo::IOLoop::ReadWriteProcess=HASH(0x145fb9d0)') called at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/IOLoop/ReadWriteProcess.pm line 325
    eval {...} called at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/IOLoop/ReadWriteProcess.pm line 325
    Mojo::IOLoop::ReadWriteProcess::_fork('Mojo::IOLoop::ReadWriteProcess=HASH(0x145fb9d0)', 'CODE(0x14659fa8)') called at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/IOLoop/ReadWriteProcess.pm line 476
    Mojo::IOLoop::ReadWriteProcess::start('Mojo::IOLoop::ReadWriteProcess=HASH(0x145fb9d0)') called at /usr/lib/os-autoinst/autotest.pm line 237
    autotest::start_process() called at /usr/bin/isotovideo line 265

[2018-08-27T15:20:24.0413 UTC] [debug] [autotest] process exited: 0
[2018-08-27T15:20:25.0414 UTC] [debug] isotovideo failed

openQA test in scenario sle-15-SP1-Installer-DVD-aarch64-proxyscc_upgrade_sles12sp3_allpatterns@aarch64 fails in
patch_sle

Reproducible

Fails since (at least) Build 15.6

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by szarate over 1 year ago

  • Project changed from openQA Tests to openQA Project
  • Category changed from Bugs in existing tests to Concrete Bugs
  • Target version set to Ready

#2 Updated by mkittler over 1 year ago

The latest build seems to pass (at least the patch_sle module). In fact, the last build that failed on patch_sle was already 2 month ago. So I'm wondering whether the issue is still reproducible.

#3 Updated by okurz over 1 year ago

  • Status changed from New to Rejected
  • Assignee set to okurz

I also think to not have seen this recently and assume there is nothing we can do.

#4 Updated by coolo 9 months ago

  • Target version changed from Ready to Done

Also available in: Atom PDF