action #39905

Job trying to download worker local file "aavmf-aarch64-vars.bin" into cache and fails with 404

Added by okurz over 1 year ago. Updated 4 months ago.

Status:ResolvedStart date:17/08/2018
Priority:LowDue date:
Assignee:szarate% Done:

0%

Category:Concrete Bugs
Target version:Ready
Difficulty:
Duration:

Description

Observation

aarch64 jobs try to download an asset which is only local to the worker but not on the webui causing 404's on o3. Most likely only visible internally but can have more severe effect adding to #39743

openqa-aarch64:~ # systemctl status openqa-worker@*
…
Aug 17 14:10:18 openqa-aarch64 worker[19783]: [info] running on openqa-aarch64:2 (Linux 4.4.138-59-default #1 SMP Mon Jun 18 13:48:42 UTC 2018 (f0b8f6b) aarc>
Aug 17 14:10:18 openqa-aarch64 worker[19783]: [info] OpenQA::Worker::Cache: Initialized with http://openqa1-opensuse at /var/lib/openqa/cache, current size i>
Aug 17 14:10:18 openqa-aarch64 worker[19783]: [info] Downloading openSUSE-Tumbleweed-DVD-aarch64-Snapshot20180813-Media.iso from http://openqa1-opensuse/test>
Aug 17 14:10:19 openqa-aarch64 worker[19783]: [info] CACHE: updating the /var/lib/openqa/cache/openSUSE-Tumbleweed-DVD-aarch64-Snapshot20180813-Media.iso las>
Aug 17 14:10:19 openqa-aarch64 worker[19783]: [info] Downloading aavmf-aarch64-vars.bin from http://openqa1-opensuse/tests/734992/asset/hdd/aavmf-aarch64-var>
Aug 17 14:10:19 openqa-aarch64 worker[19783]: [error] Can't download /usr/share/qemu/aavmf-aarch64-vars.bin
Aug 17 14:10:19 openqa-aarch64 worker[19783]: Use of uninitialized value in subroutine entry at /usr/lib/perl5/vendor_perl/5.26.2/Mojo/File.pm line 84.
Aug 17 14:10:19 openqa-aarch64 worker[19783]: [info] 12439: WORKING 734992

Problem

Introduced with recent qemu rework by rpalethorpe


Related issues

Related to openQA Project - action #39743: [o3][tools] o3 unusable, often responds with 504 Gateway ... Resolved 15/08/2018
Related to openQA Project - action #39035: PFLASH files handling Resolved 01/08/2018
Related to openQA Project - action #39833: [tools] When a worker is abruptly killed, jobs get blocke... Resolved 16/08/2018

History

#1 Updated by okurz over 1 year ago

  • Related to action #39743: [o3][tools] o3 unusable, often responds with 504 Gateway Time-out added

#3 Updated by szarate over 1 year ago

Besides, the job is running :) which is the expected behavior. The handling of the uefi variables and stuff, will be addressed in the future.

#4 Updated by szarate over 1 year ago

#5 Updated by szarate over 1 year ago

  • Assignee deleted (rpalethorpe)
  • Priority changed from High to Low
  • Target version set to Ready

#6 Updated by szarate over 1 year ago

Let's have it a as a low prio, as this needs to be properly handled and the workarounds for the PFLASH variables needs to be removed, but let's add the related tickets

#7 Updated by szarate over 1 year ago

  • Related to action #39833: [tools] When a worker is abruptly killed, jobs get blocked - CACHE: Being downloaded by another worker, sleeping added

#8 Updated by mkittler 9 months ago

I'm wondering whether this is still happening or what's still missing. Considering the ticket description I'm not even sure whether the download doesn't work or the asset just isn't where it is supposed to be.

#9 Updated by okurz 4 months ago

  • Status changed from New to Resolved
  • Assignee set to szarate

I checked journalctl -u openqa-worker@\* on aarch64.o.o and could not find the error message [error] Can't download /usr/share/qemu/aavmf-aarch64-vars.bin anymore so this issue seems to be really fixed by the PRs mentioned by szarate. The part about "uninitialized value" still happens, I will create another specific ticket ticket for that. So thanks to Santi! :)

EDIT: The "uninitialized value" also did not appear within the last jobs so I guess we are good

Also available in: Atom PDF