Project

General

Profile

Actions

action #39857

closed

[sle][functional][s390x][u] test fails in bootloader_s390 - install parameter in FTPBOOT PARM file gets truncated

Added by mloviska almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 21
Start date:
2018-08-16
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-s390x-smb+xfs@s390x-zVM-vswitch-l3 fails in
bootloader_s390

BYTES {"proxy_console_call":{"console":"x3270","args":["String(\"install=smb://openqa/inst/SLE-15-SP1-Installer-DVD-s390x-Build21.2-Media1 \")","Newline","String(\"regurl=http://all-21.2.proxy.scc.suse.de Hostname=s390vsw146.suse.de    \")","Newline","String(\"WriteChannel=0.0.0701 VNCPassword=nots3cr3t sshpassword=nots3cr3t VNC=1 \")","Newline","String(\"HostIP=10.161.157.146/20 Gateway=10.161.159.254 Nameserver=10.160.0.1  \")","Newline","String(\"VNCSize=1024x768 InstNetDev=osa Domain=suse.de Portname=VSWN1 Layer2=0 \")","Newline","String(\"ReadChannel=0.0.0700 DataChannel=0.0.0702 OSAInterface=qdio PortNo=0 \")","Newline","String(\"OSAMedium=eth sshd=1 \")","Newline","","ENTER","ENTER"],"json_cmd_token":"MOMLExai","function":"sequence_3270"},"json_cmd_token":"xmFQgFvr"}
BYTES {"json_cmd_token":"rLNcGVbz","last_screenshot_data":{"json_cmd_token":"gyJCBGZy"}}
BYTES {"json_cmd_token":"PcIGDaQz","last_screenshot_data":{"json_cmd_token":"bjyVsLDo"}}
[2018-08-16T12:24:22.0866 CEST] [debug] /var/lib/openqa/cache/tests/sle/tests/installation/bootloader_s390.pm:154 called backend::console_proxy::__ANON__
[2018-08-16T12:24:22.0866 CEST] [debug] <<< backend::console_proxy::__ANON__(wrapped_call={
  'console' => 'x3270',
  'args' => [
              'buffer_ready',
              qr/(?^:X E D I T)/
            ],
  'function' => 'expect_3270'
})
BYTES {"proxy_console_call":{"args":["buffer_ready","(?^:X E D I T)"],"json_cmd_token":"EPCWKXYa","function":"expect_3270","console":"x3270"},"json_cmd_token":"qqMdiHQR"}
expect_3270 queue content:
     FTPBOOT  PARM     T1  V 80  Trunc=80 Size=9 Line=7 Col=1 Alt=7                 
    DMSXMD587I XEDIT:                                                               
    00000 * * * Top of File * * *                                                   
    00001 install=smb://openqa/inst/SLE-15-SP1-Installer-DVD-s390x-Build21.2-Media  
    00002 regurl=http://all-21.2.proxy.scc.suse.de Hostname=s390vsw146.suse.de      
    00003 WriteChannel=0.0.0701 VNCPassword=nots3cr3t sshpassword=nots3cr3t VNC=1   
    00004 HostIP=10.161.157.146/20 Gateway=10.161.159.254 Nameserver=10.160.0.1     
    00005 VNCSize=1024x768 InstNetDev=osa Domain=suse.de Portname=VSWN1 Layer2=0    
    00006 ReadChannel=0.0.0700 DataChannel=0.0.0702 OSAInterface=qdio PortNo=0      
    00007 OSAMedium=eth sshd=1                                                      
          |...+....1....+....2....+....3....+....4....+....5....+....6....+....7..  
    00008 TERM=dumb manual=1                                                        
    00009                                                                           
    00010 * * * End of File * * *  

00001 install=smb://openqa/inst/SLE-15-SP1-Installer-DVD-s390x-Build21.2-Media got truncated in the last character, despite that Trunc is set to 80 characters.
I guess that LREC parameter is set to 72.

Reproducible

Fails since (at least) Build 15.6

Expected result

Last good: sle15gm

Further details

Always latest result in this scenario: latest


Related issues 2 (1 open1 closed)

Related to openQA Tests - action #43655: [qe-core][functional] Increase robustness of using bootloader parameter with info-file instead of long typingWorkablebinary_sequence

Actions
Related to openQA Tests - action #47879: [functional][u][s390x] test fails in bootloader_s390: smb test is not booting the installer over info-fileRejectedmgriessmeier2019-02-14

Actions
Actions #1

Updated by mloviska almost 6 years ago

  • Description updated (diff)
Actions #2

Updated by okurz almost 6 years ago

  • Due date set to 2018-09-11
  • Priority changed from Normal to Urgent
  • Target version set to Milestone 19

impacting most (all?) zVM tests right now

Actions #3

Updated by okurz almost 6 years ago

  • Subject changed from [sle][functional][s390x][u] test fails in bootloader_s390 - install parameter in FTPBOOT PARM file gets truncated to [sle][functional][s390x][u][fast] test fails in bootloader_s390 - install parameter in FTPBOOT PARM file gets truncated
  • Due date changed from 2018-09-11 to 2018-08-28
  • Status changed from New to In Progress
  • Assignee set to okurz

labeled all zVM failures on SLE15SP1 with it, @mgriessmeier mentioned a problem in the underlying z/VM infrastructure, could be fixed by now, let's see if restart helps.

Actions #4

Updated by okurz almost 6 years ago

  • Subject changed from [sle][functional][s390x][u][fast] test fails in bootloader_s390 - install parameter in FTPBOOT PARM file gets truncated to [sle][functional][s390x][u] test fails in bootloader_s390 - install parameter in FTPBOOT PARM file gets truncated
  • Due date changed from 2018-08-28 to 2018-09-25
  • Status changed from In Progress to Workable
  • Assignee deleted (okurz)
  • Priority changed from Urgent to Normal

https://openqa.suse.de/tests/1971324 passed the initial step so the intermediate problem is solved, back to the original problem now

Actions #5

Updated by mgriessmeier almost 6 years ago

@mloviska: I've tried a lot around line continuation, playing around with trunc and lrec etc. with no success :/
do you have any other idea here? otherwise we'd need to workaround this by e.g. using an url shortener I guess

Actions #6

Updated by mloviska almost 6 years ago

@mgriessmeier, have you tried to create a new file with different LREC ?
https://www.ibm.com/support/knowledgecenter/en/SSB27U_6.4.0/com.ibm.zvm.v640.dmsb3/crecfmt.htm#crecfmt
I will try to find something else, but from the top of my head I cannot recall any other solution.

Actions #7

Updated by mgriessmeier almost 6 years ago

  • Assignee set to mgriessmeier

mloviska wrote:

@mgriessmeier, have you tried to create a new file with different LREC ?
https://www.ibm.com/support/knowledgecenter/en/SSB27U_6.4.0/com.ibm.zvm.v640.dmsb3/crecfmt.htm#crecfmt
I will try to find something else, but from the top of my head I cannot recall any other solution.

will recheck with ihno and gerhard

Actions #8

Updated by mgriessmeier almost 6 years ago

  • Due date changed from 2018-09-25 to 2018-10-09
Actions #9

Updated by okurz over 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: smb+xfs@s390x-zVM-vswitch-l3
https://openqa.suse.de/tests/2095643

Actions #10

Updated by mgriessmeier over 5 years ago

  • Due date deleted (2018-10-09)
  • Assignee deleted (mgriessmeier)
  • Target version changed from Milestone 19 to Milestone 20

no time/ideas to work on this at the moment.
Since this failed for a long time, I have removed it from Functional Group and move to test development job group for SLE15
-> https://openqa.suse.de/group_overview/96

Actions #11

Updated by mgriessmeier over 5 years ago

picking up again
most likely looking forward to a solution which makes use of short links from s.qa.suse.de - any objections regarding that?

Actions #12

Updated by mgriessmeier over 5 years ago

  • Status changed from Workable to In Progress
  • Assignee set to mgriessmeier
Actions #13

Updated by mgriessmeier over 5 years ago

  • Related to action #43655: [qe-core][functional] Increase robustness of using bootloader parameter with info-file instead of long typing added
Actions #14

Updated by mgriessmeier over 5 years ago

so the best possibility to move on here is to use the info-file approach from #43655 and for generating this file to use a similiar approach like we do for AY profile generation - I will try that out and come up with a PR

Actions #15

Updated by okurz over 5 years ago

  • Target version changed from Milestone 20 to Milestone 21
Actions #16

Updated by mgriessmeier over 5 years ago

  • Status changed from In Progress to Feedback

PR opened which is fixing this only for SMB, but open for discussion to extend it:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6310

Actions #17

Updated by mgriessmeier over 5 years ago

PR merged, test running on o.s.d in testdev: https://openqa.suse.de/tests/2292442#live
will await if it succeeds and if yes, move the job back to functional group

Actions #18

Updated by mgriessmeier over 5 years ago

  • Status changed from Feedback to Resolved

https://openqa.suse.de/tests/2292584 works in functional job group -> resolving

Actions #19

Updated by mgriessmeier over 5 years ago

  • Related to action #47879: [functional][u][s390x] test fails in bootloader_s390: smb test is not booting the installer over info-file added
Actions

Also available in: Atom PDF