Project

General

Profile

action #39200

[functional][u] Change colour depth of product VNC from 16 to 24

Added by nicksinger about 2 years ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Category:
Infrastructure
Target version:
Start date:
2018-08-06
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

While reviewing SLE15SP1 I realized that colors on s390x are different to other architectures.
Compare a "good" screenshot from e.g. x86_64: https://openqa.suse.de/tests/1891706#step/welcome/1 with a badly colored one: https://openqa.suse.de/tests/1891468#step/welcome/2
The SUSE logo on the good one has a color-value of 0xffffff while the bad one has 0xf8fcf8.
Seems like this shift in color is introduced by the additional layers in remote jobs. IPMI has the same problem: https://openqa.suse.de/tests/1896186#step/welcome/1

I'm pretty sure that this is not a product regression since we've it on SLE15 as well as 12SP4 - besides that also really old jobs show the wrong color too:
https://openqa.suse.de/tests/1585180#step/welcome/1

History

#1 Updated by coolo about 2 years ago

How does vnc behave if you do a manual VNC installation?

#2 Updated by nicksinger about 2 years ago

coolo wrote:

How does vnc behave if you do a manual VNC installation?

Doesn't seem to be caused by VNC. Manually (qemu/x86_64) all colors are fine and https://openqa.suse.de/tests/1891865#step/welcome/1 also confirms it. For the sake of completeness, let me check s390x too.

This leaves the X/IceWM as leftover suspects, right?

#3 Updated by okurz about 2 years ago

  • Category set to 132

nicksinger wrote:

This leaves the X/IceWM as leftover suspects, right?

Yes, I suspect the same. So far we accepted that by creating specific needles.

Would be cool if we find a way to tweak the X server to show the same color range. Maybe you find something during your research on this?

#4 Updated by nicksinger about 2 years ago

  • Category deleted (132)

Tested again on s390 kvm with manual VNC connection -> 0xffffff, meaning: works.

#5 Updated by coolo about 2 years ago

hmm, can you bring up test system into this screen so I can do some experiments myself? In dubio take a grenache LPAR :)

#6 Updated by nicksinger about 2 years ago

coolo wrote:

hmm, can you bring up test system into this screen so I can do some experiments myself? In dubio take a grenache LPAR :)

http://loewe.arch.suse.de/tests/1107#live

guess you already know the PW to loewe ;) Please leave it in a workable state without hot-patches since other engineers may require the resources configured on there.

#7 Updated by coolo about 2 years ago

as I suspected: the vnc server of the product defaults to 16bit pixels - which means a natural colour reduction. 4 bits for red and blue and 8 for green - and you can see that the vnc image is a little greener than it should be :)

The trick is to default to full colour (as vncviewer does), but there is no negotation implemented in os-autoinst. So use depth => 24 in the console setup of 'installation'

#8 Updated by coolo about 2 years ago

  • Project changed from openQA Project to openQA Tests
  • Subject changed from Colors on remote-backends are different to "native" qemu jobs to Change colour depth of product VNC from 16 to 24

#9 Updated by okurz about 2 years ago

  • Subject changed from Change colour depth of product VNC from 16 to 24 to [functional][u] Change colour depth of product VNC from 16 to 24
  • Category set to Infrastructure
  • Target version set to future

I guess it's "infrastructure", or is it?

#10 Updated by SLindoMansilla 7 months ago

  • Status changed from New to Rejected
  • Assignee set to SLindoMansilla

The color differences are not visible anymore:

#11 Updated by okurz 7 months ago

Cool! Some maybe something actually fixed this? What I see though is slight differences in the font rendering but the important part is that the very same needle is used in both cases.

Also available in: Atom PDF