Project

General

Profile

action #38783

action #38837: [qam][functional][fast] test fails during check_screen

[qam] [wayland] test sometimes fails in window_system

Added by osukup almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Enhancement to existing tests
Target version:
-
Start date:
2018-07-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Desktop-DVD-Updates-x86_64-qam-regression-piglit@64bit-virtio-vga fails in
window_system

Reproducible

Fails since (at least) Build 20180724-1

Expected result

Last good: 20180723-3 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #45677: test fails in window_system - variable XDG_SESSION_TYPE is not definedResolved2019-01-03

History

#1 Updated by jbaier_cz almost 4 years ago

  • Subject changed from [qam] [wayland] test fails in window_system to [qam] [wayland] test sometimes fails in window_system
  • Category changed from Bugs in existing tests to Enhancement to existing tests

I suspect this is more a timing issue, something similar to https://progress.opensuse.org/issues/30613

Seems failing only on machines with virtio-vga. Restart helps most of the time.

Note to myself: switch from script_output call as it seems to be not fully reliable.

#2 Updated by jbaier_cz almost 4 years ago

  • Status changed from New to Blocked
  • Parent task set to #38837

#4 Updated by pcervinka almost 4 years ago

  • Priority changed from Normal to High

There many failures in SLE15 tests in window_system:
https://openqa.suse.de/tests/overview?distri=sle&version=15&build=20180828-4&groupid=165

Could you please check it?

Also current status is blocked by poo#38837, which is already resolved.

#5 Updated by jbaier_cz almost 4 years ago

https://openqa.suse.de/tests/1978727#step/window_system/4 show error in the typing of the command, so the script_output call is the one to blame.

Failures in SLE15 are due to font change and thus the x11_start_program fails.

#6 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-regression-piglit@64bit-virtio-vga
https://openqa.suse.de/tests/2040914

#7 Updated by jbaier_cz over 3 years ago

  • Related to action #45677: test fails in window_system - variable XDG_SESSION_TYPE is not defined added

#8 Updated by jbaier_cz over 3 years ago

  • Status changed from Blocked to Resolved

Test rewritten to use select_serial_terminal.

Also available in: Atom PDF