Project

General

Profile

action #45677

test fails in window_system - variable XDG_SESSION_TYPE is not defined

Added by jbaier_cz over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-01-03
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Desktop-DVD-Updates-x86_64-qam-regression-message@64bit fails in
window_system

This variable should be defined by the session manager and can be used to distinguish between x11 and wayland session.

Reproducible

Fails since (at least) Build 20190102-2 (current job)

Expected result

Last good: 20190102-1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #38783: [qam] [wayland] test sometimes fails in window_systemResolved2018-07-24

History

#2 Updated by jbaier_cz over 3 years ago

  • Related to action #38783: [qam] [wayland] test sometimes fails in window_system added

#4 Updated by zcjia over 3 years ago

Hi, your changes caused a failure in https://openqa.suse.de/tests/2364491#step/window_system/10 , because this is a VNC test case, the network is different.

I think you can fix this by adding "type_command" parameter to "script_output".

#5 Updated by jbaier_cz over 3 years ago

  • Status changed from Resolved to In Progress

#6 Updated by jbaier_cz over 3 years ago

  • Status changed from In Progress to Resolved

#7 Updated by GraceWang over 3 years ago

It looks like the root user didn't logout before the end of window_system.
The failure of https://openqa.suse.de/tests/2384774#step/xrdp_server/64 is caused by this.

So, it is necessary to logout the root user before the end of window_system.

Also available in: Atom PDF