action #38270

[functional][y][sporadic][aarch64] test fails in yast2_i - missing keys while searching for a package name

Added by oorlov over 1 year ago. Updated 12 months ago.

Status:RejectedStart date:06/07/2018
Priority:LowDue date:
Assignee:riafarov% Done:

0%

Category:Bugs in existing tests
Target version:QA - future
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-aarch64-allpatterns@aarch64 fails in
yast2_i

The test searches for a 'yast2-nfs-client', then removes all the characters by iterating a loop for (1 .. length($pkgname)) { send_key "backspace" }.

But in the current build it is failed because it removed several characters and then missed keys (probably because of some slowness of the system).

Suggestion

Use send_key_until_needlematch method instead of just looping for the exact number of characters in the package name.

Reproducible

Fails since (at least) Build 0245

Expected result

Last good: 0243 (or more recent)

Further details

Always latest result in this scenario: latest

Workaround


Related issues

Related to openQA Tests - action #39011: [functional] Low performance on openqa production server Resolved 01/08/2018

History

#1 Updated by oorlov over 1 year ago

  • Subject changed from test fails in yast2_i to test fails in yast2_i - missing keys while searching for a package name

#2 Updated by oorlov over 1 year ago

  • Subject changed from test fails in yast2_i - missing keys while searching for a package name to [functional][y][sporadic]test fails in yast2_i - missing keys while searching for a package name

#3 Updated by oorlov over 1 year ago

  • Description updated (diff)

#4 Updated by oorlov over 1 year ago

  • Subject changed from [functional][y][sporadic]test fails in yast2_i - missing keys while searching for a package name to [functional][y][sporadic][aarch64] test fails in yast2_i - missing keys while searching for a package name

#5 Updated by okurz over 1 year ago

  • Target version set to future

#6 Updated by okurz over 1 year ago

  • Description updated (diff)
  • Priority changed from Normal to Low

Interesting case. If found again we should prioritize higher. Please mention subsequent failures here but retrigger the failed jobs.

#7 Updated by okurz over 1 year ago

  • Related to action #39011: [functional] Low performance on openqa production server added

#8 Updated by riafarov 12 months ago

  • Status changed from New to Rejected
  • Assignee set to riafarov

Same as for #38294, both issues occurred at the same timeframe. Nothing to be addressed atm.

Also available in: Atom PDF