action #38294

[functional][y][sporadic][aarch64] - test fails in yast2_lan_restart_devices - missed 'alt-n' key

Added by oorlov over 1 year ago. Updated 12 months ago.

Status:RejectedStart date:06/07/2018
Priority:NormalDue date:
Assignee:riafarov% Done:

0%

Category:Bugs in existing tests
Target version:QA - future
Difficulty:
Duration:

Description

Observation

On the video it is clearly visible, that 'alt-y' is pressed in order to select 'Dynamic address' radio button.

Then, 'alt-n' should be pressed for going to the next screen, but it doesn't happen.

openQA test in scenario sle-12-SP4-Server-DVD-aarch64-extra_tests_on_gnome@aarch64 fails in
yast2_lan_restart_devices

Suggestions

  • Make additional checks to be sure, that system reflects on the button presses, instead of just sending keys and relying on fortune;
  • Also, add small timeout between sending 'alt-y' and then 'alt-n', as currently they are pressed immediately one after other. Real user does not send the keys in a such quick way, so UI might not respond to them sometimes;
  • Run enough amount of tests to gain statistics and ensure, that the issue is not happening anymore.

Reproducible

Fails since (at least) Build 0282

Expected result

Last good: 0279 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz over 1 year ago

  • Target version set to future

#2 Updated by riafarov 12 months ago

  • Status changed from New to Rejected
  • Assignee set to riafarov

Multiple improvements were introduced since then + we cannot investigate the issue (no logs available) + there we issues with typing in general which we have from time to time.

Also available in: Atom PDF