Project

General

Profile

action #36802

[functional][u][sporadic] test fails in consoletest_setup

Added by dheidler over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-06-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-aarch64-extra_tests_on_gnome@aarch64 fails in
consoletest_setup

Further details

Always latest result in this scenario: latest

This is a sporadic issue due to BTRFS kernel messages spamming the tty and breaking the needle matching.

Possible workarounds:


Related issues

Related to openQA Tests - action #13304: [sle][functional][u][opensuse][medium] Check plymouth splash screen is not interrupted by ugly console output if 'quiet'Rejected2016-08-22

Is duplicate of openQA Tests - action #19398: [functional][y] Handle console messages covering ncurses dialogs (was: Remove "console=tty" boot option for installed system)Rejected2017-05-26

History

#1 Updated by dheidler over 3 years ago

  • Subject changed from test fails in consoletest_setup to test fails in consoletest_setup (sporadically)

#2 Updated by dheidler over 3 years ago

  • Subject changed from test fails in consoletest_setup (sporadically) to test fails in consoletest_setup (not always)

#3 Updated by okurz over 3 years ago

Hi dheidler please use our common component and team markers for the subject line, e.g. "[functional][u][sporadic] …" as well as provide a proper "expected result". Keep in mind that the ticket reporting template is just a "template". You can fill it with real content and you can also delete parts which you see are not fitting at all. "Last good: (unknown) (or more recent)" only means that the openQA bug reporting template generation code could not find a "last good" but I guess you can be smarter than a script ;)

#4 Updated by dheidler over 3 years ago

  • Subject changed from test fails in consoletest_setup (not always) to [functional][u][sporadic] test fails in consoletest_setup

#5 Updated by dheidler over 3 years ago

  • Description updated (diff)

#6 Updated by dheidler over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to dheidler

#8 Updated by okurz over 3 years ago

  • Is duplicate of action #19398: [functional][y] Handle console messages covering ncurses dialogs (was: Remove "console=tty" boot option for installed system) added

#9 Updated by okurz over 3 years ago

  • Status changed from In Progress to Rejected

Please see https://progress.opensuse.org/issues/19398 as well for a bit bigger context.

#10 Updated by okurz over 3 years ago

  • Related to action #13304: [sle][functional][u][opensuse][medium] Check plymouth splash screen is not interrupted by ugly console output if 'quiet' added

#11 Updated by dheidler over 3 years ago

okurz: how are we going to login to run cron jobs when the needles won't match?

#12 Updated by okurz over 3 years ago

by either fixing the product or our console options in the bootloader

Also available in: Atom PDF