Project

General

Profile

action #34273

[sle][functional][sle15][y][medium] select phub module properly after bsc#1056047 has been closed

Added by okurz about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-04-04
Due date:
2018-06-05
% Done:

0%

Estimated time:
Difficulty:
medium
Duration: 45

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-allmodules+allpatterns@64bit fails to find the module "phub" in
scc_registration even though it's visible. Seems we never had this needle.

Acceptance criteria

  • AC1: DONE: workaround from lib/registration is removed as the bug is closed
  • AC2: DONE: module "phub" is selected in "allmodules" scenario as well as allmodules+allpatterns
  • AC3: allmodules+allpatterns also installs patterns from packagehub as available
  • AC4: DONE: other scenarios are still working fine without phub selected

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #20136: [sle][packagehub][opensuse][epic] packagehub testingWorkable2017-06-28

History

#1 Updated by okurz about 2 years ago

  • Target version set to Milestone 15

#2 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional][sle15][y] select phub module properly after bsc#1056047 has been closed to [sle][functional][sle15][y][medium] select phub module properly after bsc#1056047 has been closed
  • Due date changed from 2018-05-08 to 2018-05-22
  • Target version changed from Milestone 15 to Milestone 16
  • Difficulty set to medium

S16 is pretty full, we estimated to medium so we have too many of these. We could wait for the phub SLE15 kde pattern to appear.

#3 Updated by okurz about 2 years ago

  • Description updated (diff)

commit 8e607104
Author: qmsu qmsu@suse.com
Date: Thu Apr 12 05:39:41 2018 +0200

Remove workaround of package hub registration

Remove workaround for boo#1056047, bug has been fixed and
the workaround itself leads to problem now
Remove workaround for bsc#1046172, the issue has been gone
no registration code is asked for package hub neither for
SLE 12-SP3 nor 15.
Increase timeout to 5s for SUT responsing to key 'down'
-poo#34459

removed the workaround.

https://openqa.suse.de/tests/1676092#step/scc_registration/25 shows that "phub" is enabled as module in allmodules+allpatterns.

https://openqa.suse.de/tests/1675854#step/select_patterns_and_packages/120 shows that even KDE is selected but there is a package conflict but that is not raised as a test failure. Only a soft failure to the VERIFIED FEATURE bug https://bugzilla.suse.com/show_bug.cgi?id=1084064 is recorded. Shouldn't the test fail when patterns can not be installed?

JERiveraMoya you changed that piece of code I think introducing the soft-failure. Do you understand why the test module does not fail? I guess the soft-fail on the above bug should be removed and there should rather be specific soft-failures to the indidvidual package installation issues.

https://bugzilla.suse.com/show_bug.cgi?id=1091985 is a bug report by me about some unresolved dependencies but I suggest to use specific bug reports with links to individual error popups.

#4 Updated by JERiveraMoya about 2 years ago

  • Assignee set to JERiveraMoya

#5 Updated by JERiveraMoya about 2 years ago

As described in the bug the problem is that all is selectable in YaST and is suggested to open a feature request due to there's currently no way to get this behavior changed.
I was asking in #yast channel and I got this info:

  • In order to prevent the selection, they should check all the packages conflicts every time user selects one.
  • In general they do not expect too many patterns to conflict.
  • User would hate a system that disables one box because another one was checked without presenting the information about what's going on, specially in a expert-targeted screen with dozens of interconnected checkboxes.

In summary, for what I could check we could file different bugs for those "nothing provides ..." dependencies but for the case of the cloud pattern is a little different with the "CLOUD PATTERN X -ALL" checkboxes which is not clear. I will try to think how to create individual soft-failure for those notifications.

#6 Updated by JERiveraMoya about 2 years ago

  • Status changed from Workable to In Progress

Verified manually that all cloud patterns are incompatible among each others except OpenStack. That is ok for the reasons above related with the design of the dialog.
For the missing dependencies after adding phub:
KDE patterns: https://bugzilla.suse.com/show_bug.cgi?id=1093073

#7 Updated by JERiveraMoya about 2 years ago

  • Status changed from In Progress to Feedback

#8 Updated by okurz about 2 years ago

  • Related to action #20136: [sle][packagehub][opensuse][epic] packagehub testing added

#9 Updated by JERiveraMoya about 2 years ago

  • Status changed from Feedback to Resolved

Closed accidentally.

#10 Updated by JERiveraMoya about 2 years ago

  • Status changed from Resolved to In Progress

As requested, created more specific needles related with bug product. Local verification: http://dhcp254.suse.cz/tests/1261

#11 Updated by JERiveraMoya about 2 years ago

  • Status changed from In Progress to Feedback

#12 Updated by riafarov about 2 years ago

  • Due date changed from 2018-05-22 to 2018-06-05

#13 Updated by JERiveraMoya about 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF