action #34099

[sle][functional][y][medium] Need to enable updates when using modules from SCC

Added by okurz about 2 years ago. Updated almost 2 years ago.

Status:ResolvedStart date:30/03/2018
Priority:NormalDue date:22/05/2018
Assignee:okurz% Done:

0%

Category:Bugs in existing tests
Target version:openQA Project - Milestone 16
Difficulty:medium
Duration: 38

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-x86_64-gnome+proxy_SCC+allmodules@64bit fails in
select_patterns_and_packages
and we have a bug report about that bsc#1072608. Problem is that when we enable modules we need to install updates as well. This behaviour was changed with https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3564/files#diff-20d5ac8e14a1b34024fdda71020f2257R86 to enable how we currently test SLE15 with all module repositories synced to osd but AFAIK no update repos which would be needed additionally. For our SLE12 tests enabling modules we never needed to sync modules because we just the ones on SCC as their was much less reliance on a build-sync of the base product and modules and within the code stream the code has to be ABI compatible to older SLE12 versions anyway. But now even for SLE12 the module structure needed to be adapted and we need the updates enabled during installation so we should click "yes" on the button asking for updates.

Reproducible

Fails consistently since we have SLE12SP4 and also since https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3564

Acceptance criteria

  • AC1: All SLE tests using modules also enable updates except for zero/one scenario with explicit disabling of updates and checking that we hit an error
  • AC2: Feedback on the bug is provided that the test was adapted (this does not fix the bug as the user could still select the wrong option)

Suggestions

Further details

Always latest result in this scenario: latest


Related issues

Blocks openQA Tests - action #20136: [sle][packagehub][opensuse][epic] packagehub testing Workable 28/06/2017

History

#1 Updated by okurz almost 2 years ago

  • Related to action #20136: [sle][packagehub][opensuse][epic] packagehub testing added

#2 Updated by okurz almost 2 years ago

  • Related to deleted (action #20136: [sle][packagehub][opensuse][epic] packagehub testing)

#3 Updated by okurz almost 2 years ago

  • Blocks action #20136: [sle][packagehub][opensuse][epic] packagehub testing added

#4 Updated by mgriessmeier almost 2 years ago

  • Subject changed from [sle][functional][y]Need to enable updates when using modules from SCC to [sle][functional][y][medium] Need to enable updates when using modules from SCC
  • Status changed from New to Workable

#5 Updated by mgriessmeier almost 2 years ago

  • Target version changed from Milestone 15 to Milestone 16

#6 Updated by cwh almost 2 years ago

  • Difficulty set to medium

#7 Updated by okurz almost 2 years ago

  • Due date changed from 08/05/2018 to 22/05/2018

#8 Updated by riafarov almost 2 years ago

  • Assignee set to riafarov

#9 Updated by okurz almost 2 years ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5002

merged. This turns around the default now for SLE12 to the pre-2017-09 setting and allows now with the explicit test variable DISABLE_SLE_UPDATES to still disable SLE updates when we want.

Triggered some tests to check how they behave:

openqa_clone_job_osd --skip-chained-deps 1675854 TEST=allmodules+allpatterns+disable_updates _GROUP="Test Development: SLE 15" DISABLE_SLE_UPDATES=1
openqa_clone_job_osd --skip-chained-deps 1676427 TEST=default+disable_updates _GROUP="Test Development: SLE 15" DISABLE_SLE_UPDATES=1
openqa_clone_job_osd --skip-chained-deps 1676538 TEST=allmodules+disable_updates _GROUP="Test Development: SLE 15" DISABLE_SLE_UPDATES=1
openqa_clone_job_osd --skip-chained-deps 1676427 TEST=default2 _GROUP="Test Development: SLE 15"
openqa_clone_job_osd --skip-chained-deps 1676538 TEST=allmodules2 _GROUP="Test Development: SLE 15"
openqa_clone_job_osd --skip-chained-deps 1675854 TEST=allmodules+allpatterns2 _GROUP="Test Development: SLE 15"
openqa_clone_job_osd --skip-chained-deps 1676538 TEST=allmodules+enable_updates _GROUP="Test Development: SLE 15" DISABLE_SLE_UPDATES=0

-> allmodules+allpatterns+disable_updates
-> default+disable_updates
-> allmodules+disable_updates
-> default
-> allmodules
-> allmodules+allpatterns
-> allmodules+enable_updates

#10 Updated by riafarov almost 2 years ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5007 enable this behavior for SLE 15, as proxy scc replaces them properly per module

#11 Updated by riafarov almost 2 years ago

  • Status changed from Workable to Feedback

#12 Updated by okurz almost 2 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from riafarov to okurz

Seems to be fine in general, I checked allmodules+enable_updates and saw that we actually press 'alt-y' and can make that default for SLE15 as well.

sle-12-SP4-Server-DVD-x86_64-Build0239-gnome+proxy_SCC+allmodules@64bit shows that the original issue is fixed as well.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5005 is to enable updates on SLE15 as well. Merged now. https://openqa.suse.de/tests/1678962 triggered to crosscheck the second change on production instance then.

#13 Updated by okurz almost 2 years ago

  • Status changed from In Progress to Resolved

passed

Also available in: Atom PDF