Project

General

Profile

action #34063

[sled][functional][y][medium][fast] test fails in scc_registration sled_gnome+development not expecting WE license

Added by GraceWang about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-30
Due date:
2018-04-24
% Done:

0%

Estimated time:
Difficulty:
Duration: 18

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-create_hdd_sled_gnome+development@64bit-virtio-vga fails in
scc_registration

WE license appeared along with the fix for https://progress.opensuse.org/issues/33808
But the current case does not handle WE license.
So the case need to be updated accordingly.

Reproducible

Fails since (at least) Build 533.2

Expected result

Last good: 530.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #33808: [sled][functional][rsync.pl][easy] test fails in addon_products_sle because we don't sync the WE licenseResolved2018-03-262018-04-10

Related to openQA Tests - action #33943: [sle][functional][y][fast][medium] test fails in scc_registration - looks for scc-addon-license-wsm, finds addon screen, needs "alt-n" press or related to license syncing?Resolved2018-03-282018-04-10

Related to openQA Tests - action #34060: [sled][functional][y][medium] test fails in addon_products_sle of sled_gnome not expecting WE licenseResolved2018-03-302018-04-24

History

#1 Updated by GraceWang about 2 years ago

  • Related to action #33808: [sled][functional][rsync.pl][easy] test fails in addon_products_sle because we don't sync the WE license added

#2 Updated by okurz about 2 years ago

  • Related to action #33943: [sle][functional][y][fast][medium] test fails in scc_registration - looks for scc-addon-license-wsm, finds addon screen, needs "alt-n" press or related to license syncing? added

#3 Updated by okurz about 2 years ago

  • Subject changed from [sled][functional] test fails in scc_registration to [sled][functional][y] test fails in scc_registration sled_gnome+development not expecting WE license
  • Due date set to 2018-04-24
  • Priority changed from Normal to High
  • Target version set to Milestone 15

#4 Updated by yfjiang about 2 years ago

Hi all,

I was a bit hesitating how should we proceed this, when I look the related issue:

https://bugzilla.suse.com/show_bug.cgi?id=1085077
https://bugzilla.suse.com/show_bug.cgi?id=1083665
https://bugzilla.suse.com/show_bug.cgi?id=1081647

It seems the extra license will be there since bsc#1081647 was closed as a feature.
Am I right the plan in openQA is to update the test case instead of standing by the
feature implementation?

#5 Updated by okurz about 2 years ago

  • Subject changed from [sled][functional][y] test fails in scc_registration sled_gnome+development not expecting WE license to [sled][functional][y][medium] test fails in scc_registration sled_gnome+development not expecting WE license
  • Status changed from New to Workable
  • Target version changed from Milestone 15 to Milestone 16

Yes, the bug was closed as a feature but as a ECO feature so I assume we would still see changed behaviour before SLE15 GM. QSF (QA SLE functional) does not plan to update the test code currently. We are waiting for movement on the still open bug or the fate itself.

What we should still do is implement a workaround in the test

#6 Updated by okurz about 2 years ago

  • Related to action #34060: [sled][functional][y][medium] test fails in addon_products_sle of sled_gnome not expecting WE license added

#7 Updated by okurz about 2 years ago

  • Due date changed from 2018-04-24 to 2018-05-08

We are awaiting a change regarding "unified license handling" which we should see hitting the builds first before we move forward with any kind of fix -> moving to S16

#9 Updated by riafarov about 2 years ago

  • Status changed from Workable to Resolved

#10 Updated by riafarov about 2 years ago

  • Subject changed from [sled][functional][y][medium] test fails in scc_registration sled_gnome+development not expecting WE license to [sled][functional][y][medium][fast] test fails in scc_registration sled_gnome+development not expecting WE license
  • Due date changed from 2018-05-08 to 2018-04-24

Was resolved in S15 due to priority.

Also available in: Atom PDF