Project

General

Profile

action #33670

[sle][functional][u][easy][hyperv] test fails in consoletest_setup - Remove needle and verify root console is reached

Added by JERiveraMoya about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-22
Due date:
2018-05-08
% Done:

0%

Estimated time:
Difficulty:
easy
Duration: 34

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-textmode@svirt-hyperv fails in
consoletest_setup

It seems that is taking the welcome message as a correct needle for root console, so it is trying to type "root" while is changing to tty6, so we need to remove text-login-20180315 and ensure root console is reached.

Reproducible

Fails since (at least) Build 530.1 (current job)

Expected result

Last good: 527.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #34072: [functional][y][easy]test fails in yast2_tftp with premature needle matchingResolved2018-03-302018-04-24

History

#1 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional] test fails in consoletest_setup - Remove needle and verify root console is reached to [sle][functional][u] test fails in consoletest_setup - Remove needle and verify root console is reached
  • Due date set to 2018-04-24
  • Priority changed from Normal to High
  • Target version set to Milestone 15

#2 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional][u] test fails in consoletest_setup - Remove needle and verify root console is reached to [sle][functional][u][easy][hyperv] test fails in consoletest_setup - Remove needle and verify root console is reached
  • Status changed from New to Workable
  • Difficulty set to easy

#3 Updated by jorauch about 2 years ago

  • Assignee set to jorauch

#4 Updated by jorauch about 2 years ago

Error has to be located in susedistribution -> activate_console
We have to be careful here not to break other tests, I suggest putting the difficulty up because this is not trivial anymore

#5 Updated by jorauch about 2 years ago

General issue is that text login matches too easy and therefore on wrong tty
We have to reduce the priority of text_login so it looks first for ttyX selected or dont check for this at all

#6 Updated by okurz about 2 years ago

I retriggered the latest job in the scenario mentioned in the description, please monitor https://openqa.suse.de/tests/1622296#live

#7 Updated by jorauch about 2 years ago

  • Related to action #34072: [functional][y][easy]test fails in yast2_tftp with premature needle matching added

#8 Updated by jorauch about 2 years ago

  • Status changed from Workable to Feedback

Riafarov created two PRs for this:

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4855
https://github.com/os-autoinst/os-autoinst/pull/945

Those basically allow to pass a "ensure_tty" parameter

#9 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-04-24 to 2018-05-08
  • Target version changed from Milestone 15 to Milestone 16

PR merged, please verify on o.s.d

#10 Updated by okurz about 2 years ago

  • Status changed from Feedback to Resolved

https://openqa.suse.de/tests/1655610 and last 15 jobs in this scenario at least did not fail on this.

Also available in: Atom PDF