Project

General

Profile

action #32542

[opensuse][tw][functional][aarch64] test fails in logs_from_installation_system - because of unexpected token

Added by zluo over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Start date:
2018-02-28
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-aarch64-ext4@aarch64 fails in
logs_from_installation_system

Reproducible

Fails since (at least) Build 20180220

Expected result

Last good: 20180218 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #32932: [sle][functional][u][hyperv] test fails in logs_from_installation_system - Increase timeout for uploading logsResolved2018-03-08

History

#1 Updated by okurz over 2 years ago

  • Subject changed from [openSUSE TW][functional][aarch64] test fails in logs_from_installation_system - because of unexpected token to [opensuse][tw][functional][aarch64] test fails in logs_from_installation_system - because of unexpected token
  • Target version set to Milestone 16

please always use lowercase subject tags

#3 Updated by StefanBruens about 2 years ago

OT - is there a way to make a "Private" note public?

Someone has messed up the local instance, it does not match the code published on github:

sub save_and_upload_log {
    my ($self, $cmd, $file, $args) = @_;
    script_run("$cmd | tee $file", $args->{timeout});
    upload_logs($file) unless $args->{noupload};
    save_screenshot if $args->{screenshot};
}

https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/08b8e09d69efb174ea827eda2518cd928e594e56/lib/opensusebasetest.pm#L35

While the exeduted code is:

script_run("$cmd > tee $file", $args->{timeout});

i.e. it instead of piping the output through "tee", it is redirected to the file "tee".

Compare screenshots https://openqa.opensuse.org/tests/619444#step/logs_from_installation_system/24 and https://openqa.opensuse.org/tests/622414#step/logs_from_installation_system/24

#4 Updated by okurz about 2 years ago

  • Related to action #32932: [sle][functional][u][hyperv] test fails in logs_from_installation_system - Increase timeout for uploading logs added

#5 Updated by okurz about 2 years ago

  • Category changed from Bugs in existing tests to Infrastructure
  • Status changed from New to Resolved
  • Assignee set to okurz

I am pretty sure the problem has been caused by an upgrade of qemu on the worker host. The log of a failing tests states: "QEMU emulator version 2.11.0". https://bugs.launchpad.net/qemu/+bug/1738283 is the corresponding upstream bug. https://openqa.opensuse.org/tests/625561 shows the test working again with "QEMU emulator version 2.11.1".

Also available in: Atom PDF