Project

General

Profile

Actions

action #29393

closed

[sle][functional][tools] test fails in bootloader_s390 - check settings of samba server on o.s.d

Added by mgriessmeier over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-12-14
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-s390x-smb+xfs@s390x-zVM-vswitch-l2 fails in
bootloader_s390

installation over smb fails:

expect_3270 qeue content:
    FS-Cache: Netfs 'cifs' registered for caching                                   
    Key type cifs.spnego registered                                                 
    Key type cifs.idmap registered                                                  
    CIFS VFS: Error connecting to socket. Aborting operation.                       
    CIFS VFS: cifs_mount failed w/return code = -111                                

Reproducible

Fails since (at least) Build 360.1

Expected result

Last good: 358.1 (or more recent)

AC1: Installation over smb from openqa.suse.de works

Further details

H1: REJECTED: product bug, can be verified by manual testing installation over smb from dist - rejected because manual installation over smb from dist.suse.de works
H2: smb server setting on o.s.d. changed

Always latest result in this scenario: latest


Related issues 2 (0 open2 closed)

Blocks openQA Tests - action #15136: [functional][hard][yast][y] network installations over SMBRejectedokurz2017-02-09

Actions
Blocks openQA Tests - action #30640: [sle][functional]gnome_smb does not really use SMBResolvedokurz2018-01-22

Actions
Actions #1

Updated by mgriessmeier over 6 years ago

  • Description updated (diff)
Actions #2

Updated by okurz over 6 years ago

  • Target version set to Milestone 13
Actions #3

Updated by okurz over 6 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: smb+xfs@s390x-zVM-vswitch-l2
https://openqa.suse.de/tests/1396170

Actions #4

Updated by okurz about 6 years ago

  • Blocks action #15136: [functional][hard][yast][y] network installations over SMB added
Actions #5

Updated by okurz about 6 years ago

  • Blocks action #30640: [sle][functional]gnome_smb does not really use SMB added
Actions #6

Updated by okurz about 6 years ago

  • Status changed from New to In Progress
  • Assignee set to okurz

Well, "check settings" here is easy. There is no samba server on osd.

Installed package "samba" on osd, copied back /etc/samba/smb.conf.rpmsave to /etc/samba/smb.conf and check connection from local with smbclient -N //openqa.suse.de/inst.

Retriggered s390x job: https://openqa.suse.de/tests/1405879

Actions #7

Updated by okurz about 6 years ago

  • Status changed from In Progress to Resolved

https://openqa.suse.de/tests/1405879#

but as foursixnine stated:

[22 Jan 2018 12:01:24] <okurz> foursixnine: It seems the samba server we had on osd has gone. I reinstalled it but I wonder if we need/can cover it by salt recipes. your opinion?
[22 Jan 2018 12:36:01] <foursixnine> okurz: my opinion is: It should be covered by salt recipes :P
Actions #8

Updated by okurz about 6 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: smb+xfs@s390x-zVM-vswitch-l2
https://openqa.suse.de/tests/1467395

Actions

Also available in: Atom PDF