Project

General

Profile

action #28964

[sle][functional][medium] test fails in salt - No salt-master in SLES/SLED

Added by SLindoMansilla almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-12-06
Due date:
2017-12-19
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

It is expected that there is no salt-master on SLES/SLED, only salt-client. So the test has to be adapted.

openQA test in scenario sle-15-Installer-DVD-Staging:V-x86_64-cryptlvm_minimal_x@64bit-staging fails in
salt

Acceptance criteria

  • AC: The test module salt doesn't fail on functional nor staging because of salt-master doesn't exists on SLES/SLED.

Tasks

  1. Disable test module salt on staging to not block release manager. See note-1
  2. Change the test module salt to not install salt-master.
  3. Investigate how to test the salt-client on SLES/SLED.
  4. Enable the test module salt for staging.

Reproducible

Fails since (at least) Build V.206.3 (current job)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #29583: [opensuse][functional] extra_tests_in_textmode@64bit Fix salt testResolved2017-12-192018-01-16

History

#1 Updated by SLindoMansilla almost 4 years ago

okurz, please provide Expected result/Last good

#2 Updated by SLindoMansilla almost 4 years ago

  • Description updated (diff)

PR to temporary disable test module salt for staging: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4011

#3 Updated by SLindoMansilla almost 4 years ago

  • Description updated (diff)

#4 Updated by SLindoMansilla almost 4 years ago

  • Priority changed from Urgent to Normal

Staging no more blocked, so lowering the prio. When it fails in functional, please, raise prio to High

#5 Updated by okurz almost 4 years ago

  • Status changed from New to In Progress
  • Assignee set to okurz

behlert stated: is correct, there's no salt-master in SLE15. And afaik it's also not planned to have it, as SLES/SLED will only have the clients, while SUSE Manager will provide the master.

#6 Updated by okurz almost 4 years ago

  • Due date set to 2017-12-19
  • Target version set to Milestone 12

#7 Updated by okurz almost 4 years ago

  • Subject changed from [sle][functional][hard] test fails in salt - No salt-master in SLES/SLED to [sle][functional][medium] test fails in salt - No salt-master in SLES/SLED

that shouldn't be "hard" because it's only about if we schedule the test module or not.

#8 Updated by okurz almost 4 years ago

  • Status changed from In Progress to Resolved

If salt-master should be there at all will be discussed in https://bugzilla.suse.com/show_bug.cgi?id=1071451

#9 Updated by SLindoMansilla almost 4 years ago

Also we don't want to test salt-client?

#10 Updated by SLindoMansilla almost 4 years ago

  • Related to action #29583: [opensuse][functional] extra_tests_in_textmode@64bit Fix salt test added

Also available in: Atom PDF