Project

General

Profile

action #27868

Refactor openQA::Setup Configuration and logging initialization

Added by szarate almost 3 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2017-11-17
Due date:
2020-04-08
% Done:

0%

Estimated time:
Difficulty:

Description

Currently all logger configuration is lives within OpenQA::Setup but it should live in it's own space like OpenQA::Configuration OpenQA::Logger so that console aplications like the worker, that do not require database don't get cluttered.


Related issues

Related to openQA Project - action #25958: [tools][sprint 201710.2][sprint 201711.1][easy hack] Harmonizing logging setup across openQAResolved2017-10-11

History

#1 Updated by szarate almost 3 years ago

Maybe this is not related, but Sergio got this when trying his dockerized worker approach

Can't locate db_profiler.pm:   Permission denied at /usr/share/openqa/script/../lib/OpenQA/Setup.pm line 26.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Setup.pm line 26.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Worker.pm line 33.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Worker.pm line 33.
Compilation failed in require at /usr/share/openqa/script/worker line 106.
BEGIN failed--compilation aborted at /usr/share/openqa/script/worker line 106.

#2 Updated by szarate almost 3 years ago

  • Related to action #25958: [tools][sprint 201710.2][sprint 201711.1][easy hack] Harmonizing logging setup across openQA added

#3 Updated by SLindoMansilla almost 3 years ago

szarate wrote:

Maybe this is not related, but Sergio got this when trying his dockerized worker approach

Can't locate db_profiler.pm:   Permission denied at /usr/share/openqa/script/../lib/OpenQA/Setup.pm line 26.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Setup.pm line 26.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Worker.pm line 33.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Worker.pm line 33.
Compilation failed in require at /usr/share/openqa/script/worker line 106.
BEGIN failed--compilation aborted at /usr/share/openqa/script/worker line 106.

Not only the dockerized version. The current worker version from http://download.opensuse.org/repositories/devel:/openQA/openSUSE_Leap_42.3 have the same problem.

#4 Updated by szarate almost 3 years ago

As per poo#27934, my comment and Sergio's are not valid anymore, we could not reproduce this either.

#5 Updated by okurz over 2 years ago

  • Target version changed from future to future

#6 Updated by okurz over 1 year ago

  • Category set to Feature requests

#7 Updated by okurz 6 months ago

  • Status changed from New to In Progress
  • Assignee set to cdywan

#8 Updated by okurz 6 months ago

  • Due date set to 2020-04-08
  • Status changed from In Progress to Feedback

#9 Updated by cdywan 6 months ago

This step is probably also needed to resolve this if I understood the request correctly https://github.com/os-autoinst/openQA/pull/2912

#10 Updated by szarate 6 months ago

cdywan wrote:

This step is probably also needed to resolve this if I understood the request correctly https://github.com/os-autoinst/openQA/pull/2912

Yep, looks like so :) Thanks!

#11 Updated by cdywan 5 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF