Project

General

Profile

action #26104

test fails in yast2_lang

Added by dimstar over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-10-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_gui@64bit fails in
yast2_lang

Reproducible

Fails since (at least) Build 20171006

Expected result

Last good: 20171005 (or more recent)

Further details

Always latest result in this scenario: latest

More info

It seemd the machine 'stalled' somehow completely. yast2 does not start, the collection of debug logs fails at the point it calls 'rpmverify' and all future commands simply are ignored


Related issues

Related to openQA Tests - action #25634: [sle][functional][opensuse][sporadic]test fails in yast2_firewall because "zypper in" times out -> bump timeoutResolved2017-09-282017-11-08

Related to openQA Tests - action #27004: [opensuse][sle][functional][yast][y][hard] yast2 gui modules fail to start in the defined time frameRejected2017-10-25

History

#1 Updated by riafarov over 5 years ago

  • Assignee set to riafarov

#2 Updated by riafarov over 5 years ago

  • Status changed from New to In Progress

#3 Updated by riafarov over 5 years ago

Machine is not really stalled, we can even see that time is updated. Increasing timeout to 180 for module to start seems to help. I've added TIMEOUT_SCALE variable to the test suite on o3 to see if it helps. I could reproduce the issue in 5 out of 6 runs locally. With increased timeout in 5 runs test module haven't failed even once. Investigating if anything else can be improved.

#4 Updated by riafarov over 5 years ago

One of our hypothesis is that if btrfs balance is triggered, SUT has significant performance degradation. I was able to replicate issue when set RAM to 512 on VM, started balancing btrfs and then tried to run yast module. SUT becomes very slow and it took up to few minutes to start yast control center. Before balancing was triggered, gui shows up immediately. In the serial output we see that for the failed runs balancing is triggered.

#5 Updated by riafarov over 5 years ago

  • Status changed from In Progress to Feedback

#6 Updated by riafarov over 5 years ago

  • Status changed from Feedback to Resolved

There are 10 runs and module doesn't fail. Previously it was failing 4/8 times. See https://openqa.opensuse.org/tests/513279#previous . Please, feel free to reopen if problem occurs again.

#7 Updated by riafarov over 5 years ago

  • Related to action #25634: [sle][functional][opensuse][sporadic]test fails in yast2_firewall because "zypper in" times out -> bump timeout added

#8 Updated by riafarov over 5 years ago

  • Related to action #27004: [opensuse][sle][functional][yast][y][hard] yast2 gui modules fail to start in the defined time frame added

Also available in: Atom PDF