Project

General

Profile

action #25688

[tools][sprint 201710.1][sprint 201710.2][infrastructure] Upgrade openqa.suse.de and remote workers to sle12sp3 and 42.3

Added by szarate almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2017-09-29
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

For a while we have had openSUSE Leap 42.3 and SLE12 SP3 already available, and currently we have workers with different versions of everything.

It was agreed with the PO to do an OS upgrade, not all at once though, current situation is as follows attached to the ticket.

This is needed before we hit Beta1 and before poo#23320 is merged.


Related issues

Blocks openQA Tests - action #27502: Upgrade x86_64 workers to QEMU 2.9.* or later for Wayland testing of SLED15Resolved2017-11-08

History

#2 Updated by szarate almost 3 years ago

  • Subject changed from [tools][sprint 201709.3][infrastructure] Upgrade openqa.suse.de and remote workers to sle12sp3 and 42.2 to [tools][sprint 201710.1][infrastructure] Upgrade openqa.suse.de and remote workers to sle12sp3 and 42.2

#3 Updated by okurz almost 3 years ago

  • Subject changed from [tools][sprint 201710.1][infrastructure] Upgrade openqa.suse.de and remote workers to sle12sp3 and 42.2 to [tools][sprint 201710.1][infrastructure] Upgrade openqa.suse.de and remote workers to sle12sp3 and 42.3

#4 Updated by EDiGiacinto almost 3 years ago

  • Status changed from New to In Progress
  • Assignee set to szarate

#5 Updated by EDiGiacinto almost 3 years ago

  • Status changed from In Progress to Resolved

#6 Updated by EDiGiacinto almost 3 years ago

  • Status changed from Resolved to In Progress

#7 Updated by EDiGiacinto almost 3 years ago

  • Subject changed from [tools][sprint 201710.1][infrastructure] Upgrade openqa.suse.de and remote workers to sle12sp3 and 42.3 to [tools][sprint 201710.1][sprint 201710.2][infrastructure] Upgrade openqa.suse.de and remote workers to sle12sp3 and 42.3

#8 Updated by szarate almost 3 years ago

  • Status changed from In Progress to Feedback
  • Priority changed from High to Normal

This task is blocked currently by power8 having a peformance regression: https://bugzilla.suse.com/show_bug.cgi?id=1064407, rest of workers still need an upgrade but is feasible to performm just not scheduled yet.

Setting to feedback in the meantime.

#9 Updated by okurz almost 3 years ago

  • Blocks action #27502: Upgrade x86_64 workers to QEMU 2.9.* or later for Wayland testing of SLED15 added

#10 Updated by yfjiang almost 3 years ago

Discussed offline with Santi and Oliver, before everything is fully set, it will be helpful to enable dedicated workers with updated qemu to enable virtio snapshot -- so that wayland testing becomes possible for GNOME cases. As Oliver pointed out, a successful example can be seen in o3 where KDE was tested with a later qemu/virtio-gpu - https://openqa.opensuse.org/tests/524969

#11 Updated by michalnowak over 2 years ago

I'd really love to migrate openqaw5-xen.qa.suse.de because grub2 package from the newer release has fixes (#1054453 and #1026511) which I'd really like to have as a supported RPM package (unlike today where I have homegrown fixes).

Do I understand it correctly that openQA workers (x86_64 ones at least) were not migrated to Leap 42.3? Random set of worker I've seen was still running QEMU 2.6 from Leap 42.2.

#12 Updated by szarate over 2 years ago

  • Project changed from SUSE QA tests to openQA Project
  • Category set to 168
  • Target version set to Current Sprint

Moving this to openQA tracker. As there's no private information (main reason for creating it here)

#13 Updated by szarate over 2 years ago

  • Status changed from Feedback to Resolved

All workers that are not power8 have been sucessfully upgraded to leap 42.3. A separate ticket should be created for power (malbec)

#14 Updated by michalnowak over 2 years ago

Updated Xen host to 12 SP3.

#15 Updated by szarate over 2 years ago

  • Target version changed from Current Sprint to Done

Also available in: Atom PDF