Project

General

Profile

action #25286

[sle][functional][u][qam][tools] Wrong URL for repositories -> repo symlinks deleted on osd prematurely?

Added by dasantiago about 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
2017-09-14
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-create_hdd_minimal_base+sdk@64bit fails in
addon_products_sle

Reproducible

Fails since (at least) Build 20170914-1 (current job)

The URL for repositories is wrong. We don't want to use FTP.

Expected result

Last good: 20170913-2 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Blocked by openQA Tests - action #21038: [qam] test fails in bootloader_s390 - missing install image on ftp serverWorkable2017-08-03

History

#1 Updated by osukup about 4 years ago

interesting part is we remove ADDONURL variables in main.pm ... but here this two vars stay defined ...

#2 Updated by osukup about 4 years ago

I found the problematic line in main.pm

https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/products/sle/main.pm#L288-L344 this sets this vars unconditionally

#3 Updated by okurz about 4 years ago

  • Subject changed from Wrong URL for repositories to [sle][functional][qam]Wrong URL for repositories
  • Status changed from New to In Progress
  • Assignee set to riafarov
  • Priority changed from Normal to Urgent

please take a look into that and make sure to hand over to someone else tomorrow before your vacation

#4 Updated by riafarov about 4 years ago

  • Subject changed from [sle][functional][qam]Wrong URL for repositories to Wrong URL for repositories
  • Assignee deleted (riafarov)
  • Priority changed from Urgent to Normal

We have changed behavior of test suite quite some time ago to use ftp instead of iso, because then we can use it for SLE15 and for all architectures, as there is no SDK iso for s390x, for example. The problem though is that repos are clean up from ftp and we don't have ultimate solution for that. I have synced SDK repos for all architectures again, and will apply some workaround solution to avoid it's removal again.

#5 Updated by okurz about 4 years ago

  • Subject changed from Wrong URL for repositories to [sle][functional][qam]Wrong URL for repositories
  • Assignee set to okurz
  • Priority changed from Normal to High

I assume you didn't intend to do the changes to the fields but only tried to add a comment so readding. However, after you added symlinks it's not "urgent" anymore and I will track it during your vacation. Also, I see it strongly related to #21038 about prematurely deleted s390x ressources.

#6 Updated by okurz about 4 years ago

  • Related to action #21038: [qam] test fails in bootloader_s390 - missing install image on ftp server added

#7 Updated by okurz about 4 years ago

  • Status changed from In Progress to Feedback

done by riafarov: symlinks added and are continuously readded with cron job on osd

#8 Updated by riafarov about 4 years ago

PR with proper fix to unset ADDON, ADDONURL variables https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3576

#9 Updated by okurz about 4 years ago

  • Target version set to Milestone 11

#10 Updated by okurz almost 4 years ago

  • Due date set to 2017-10-11

#11 Updated by okurz almost 4 years ago

  • Related to deleted (action #21038: [qam] test fails in bootloader_s390 - missing install image on ftp server)

#12 Updated by okurz almost 4 years ago

  • Blocked by action #21038: [qam] test fails in bootloader_s390 - missing install image on ftp server added

#13 Updated by okurz almost 4 years ago

  • Due date deleted (2017-10-11)

removing again from sprint, blocked by #21038

#14 Updated by okurz almost 4 years ago

  • Due date set to 2017-11-08

#15 Updated by okurz almost 4 years ago

  • Subject changed from [sle][functional][qam]Wrong URL for repositories to [sle][functional][qam][tools]Wrong URL for repositories -> repo symlinks deleted on osd prematurely?
  • Due date deleted (2017-11-08)
  • Status changed from Feedback to In Progress
  • Assignee changed from okurz to szarate
  • Priority changed from High to Normal
  • Target version changed from Milestone 11 to Milestone 12

szarate could you help with this one? It seems the repo symlinks on osd are cleaned prematurely but we need them in the current implementation of tests.

#16 Updated by okurz over 3 years ago

  • Target version changed from Milestone 12 to Milestone 13

ping

#17 Updated by riafarov over 3 years ago

  • Target version changed from Milestone 13 to Milestone 14

I guess we still have no progress here, but problem is still there and repos are removed is not mentioned in parameters of the running jobs.

#18 Updated by okurz over 3 years ago

  • Due date set to 2018-03-13

#19 Updated by szarate over 3 years ago

  • Target version changed from Milestone 14 to Ready

#20 Updated by szarate over 3 years ago

  • Category changed from Bugs in existing tests to Infrastructure
  • Status changed from In Progress to New
  • Assignee deleted (szarate)

This requires a bit of investigation

#21 Updated by szarate over 3 years ago

  • Due date deleted (2018-03-13)

#22 Updated by okurz almost 3 years ago

  • Subject changed from [sle][functional][qam][tools]Wrong URL for repositories -> repo symlinks deleted on osd prematurely? to [sle][functional][u][qam][tools] Wrong URL for repositories -> repo symlinks deleted on osd prematurely?

#23 Updated by vpelcak over 2 years ago

  • Status changed from New to Closed

Works now.

#24 Updated by okurz over 2 years ago

  • Status changed from Closed to New

Yes, it "works now" but only with the hacky workaround of periodically readding a symlink on osd. This should not be considered a stable, long-term solution.

#25 Updated by okurz over 1 year ago

  • Status changed from New to Resolved
  • Assignee set to okurz
  • Target version changed from Ready to Done

Situation changed with a different handling in the openQA QAM bot triggering the tests. It might be fixed in there by adding proper repo URLs and I also think that we handle the repo symlinks differently so assuming (with low confidence on being correct) that the issue is actually fixed.

Also available in: Atom PDF