Project

General

Profile

action #24880

disable iso download in openQA

Added by lnussel about 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
QA
Target version:
Start date:
2018-05-16
Due date:
2018-05-17
% Done:

100%

Estimated time:

Description

smartypants go to openQA to download the final iso. Needs to be disable to avoid overloading the server.

Either by removing permission from the files or apache access rules.


Related issues

Copied from openSUSE Leap 42.3 Release - action #16844: disable iso download in openQAClosed2017-07-212017-07-25

Copied to openSUSE Leap 15.1 - action #47558: [functional][u] disable iso download in openQAClosed2019-05-152019-05-17

History

#1 Updated by lnussel about 4 years ago

  • Copied from action #16844: disable iso download in openQA added

#2 Updated by okurz almost 4 years ago

  • Category deleted (QA)

Isn't that a duplicate of #25092 ?

Also, would you mind if we rewrite that ticket to use

RewriteCond %{REMOTE_ADDR}       !^192\.168\.112\.
RewriteRule "/assets/iso/fixed/openSUSE-Leap-(42.[23])-(DVD|NET)-x86_64.iso" "http://download.opensuse.org/distribution/leap/$1/iso/openSUSE-Leap-$1-$2-x86_64.iso"

instead?

#3 Updated by lnussel almost 4 years ago

Indeed, I delete the other ticket, thanks

#4 Updated by lnussel over 3 years ago

  • Due date changed from 2018-04-10 to 2018-05-24
  • Start date changed from 2018-04-06 to 2018-05-20

#5 Updated by lnussel over 3 years ago

  • Due date changed from 2018-05-24 to 2018-05-17
  • Category set to QA
  • Assignee set to okurz
  • Start date changed from 2018-05-20 to 2018-05-16

#8 Updated by okurz over 3 years ago

  • Status changed from New to Resolved

IMHO done

#9 Updated by okurz over 3 years ago

  • Status changed from Resolved to Feedback

Can we find a solution to still allow us to debug something on the most recent build other than manually enabling/disabling the rewrite rules? I guess checking for the SUSE IP range will not work due to the way the requests are proxied from the outside?

#10 Updated by lnussel over 3 years ago

alternative would be to require authentication

#11 Updated by lnussel over 3 years ago

  • Status changed from Feedback to Closed

ok, closing. thanks!

#12 Updated by lnussel over 3 years ago

  • % Done changed from 0 to 100

#13 Updated by riafarov about 3 years ago

Fixed the issue for 15.1 as it was not possible to download assets as per discussion on irc:

    # Uncomment during GMC phase of Leap
#    RewriteCond %{REMOTE_ADDR}       !^192\.168\.112\.
#    RewriteRule "/assets/iso/openSUSE-Leap-(42.[23]|15.[0-9])-(.*).iso" "http://download.opensuse.org/distribution/leap/$1/iso/openSUSE-Leap-$1-$2.iso"

#14 Updated by lnussel over 2 years ago

  • Copied to action #47558: [functional][u] disable iso download in openQA added

Also available in: Atom PDF