Project

General

Profile

action #23822

[sle][functional][y][bsc#1073281][easy] new needles and workaround is needed by test module nis_server

Added by Anonymous over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2017-08-31
Due date:
2018-05-08
% Done:

0%

Estimated time:
Difficulty:
easy
Duration: 179

Description

Observation

openQA test in scenario sle-15-Leanos-DVD-x86_64-nis_server@64bit fails in
nis_server

Reproducible

Fails since (at least) Build 173.8

Expected result

Last good: SLE 12 SP3

Compare to SLE12 SP4, maybe it works fine

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #35745: [sle][functional][y][bsc#1083487] - Use static port configuration for NIS/NFS instead of disabling firewalld in MM nfs client/server test suitesWorkable2018-05-02

Has duplicate openQA Tests - action #33250: [sle][functional[yast][medium] test fails in yast2_nis, firewall not configurableResolved2018-03-142018-03-27

History

#1 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: nis_server
https://openqa.suse.de/tests/1173541

#2 Updated by okurz over 2 years ago

  • Subject changed from new needles and workaround is needed by test module nis_server to [sle][functional]new needles and workaround is needed by test module nis_server

#3 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: nis_server
https://openqa.suse.de/tests/1195289

#4 Updated by Anonymous over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Anonymous
  • Priority changed from Normal to Low

Added needle and started testrun:
https://openqa.suse.de/tests/1216276

#5 Updated by jorauch over 2 years ago

Test now needs another update to install SuSEFirewall2 from popup

#6 Updated by Anonymous over 2 years ago

Right, I am in middle of coding for this popup.

#7 Updated by okurz over 2 years ago

  • Priority changed from Low to Normal

I think the prio should not be low when we see the test failing on it. I marked the test now with bug https://bugzilla.suse.com/show_bug.cgi?id=1058012 about SuSEfirewall2 which should be replaced by firewallctl. It's better to fail in product bugs. And yes, we can try to workaround but I don't think it's that important.

#8 Updated by Anonymous over 2 years ago

  • Assignee deleted (Anonymous)

#9 Updated by okurz over 2 years ago

  • Target version set to Milestone 13

#10 Updated by okurz over 2 years ago

  • Priority changed from Normal to High

still failing in our current tests

Latest example: https://openqa.suse.de/tests/1261873

#11 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: nis_server
https://openqa.suse.de/tests/1293681

#12 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: nis_server
https://openqa.suse.de/tests/1397156

#13 Updated by okurz over 2 years ago

  • Subject changed from [sle][functional]new needles and workaround is needed by test module nis_server to [sle][functional][bsc#1073281]new needles and workaround is needed by test module nis_server
  • Due date set to 2018-02-27
  • Status changed from In Progress to Blocked
  • Assignee set to zluo
  • Target version changed from Milestone 13 to Milestone 14

Hi zluo, please track the bug https://bugzilla.suse.com/show_bug.cgi?id=1073281 you created. Let's see if the test works better after a bugfix.

#14 Updated by riafarov about 2 years ago

  • Due date changed from 2018-02-27 to 2018-03-13

#15 Updated by okurz about 2 years ago

  • Due date changed from 2018-03-13 to 2018-04-24
  • Target version changed from Milestone 14 to Milestone 15

#16 Updated by riafarov about 2 years ago

  • Has duplicate action #33250: [sle][functional[yast][medium] test fails in yast2_nis, firewall not configurable added

#17 Updated by okurz about 2 years ago

bug still open

#18 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-04-24 to 2018-05-08
  • Target version changed from Milestone 15 to Milestone 16

okurz wrote:

bug still open

still applies, moving to Sprint 16

#19 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional][bsc#1073281]new needles and workaround is needed by test module nis_server to [sle][functional][y][bsc#1073281]new needles and workaround is needed by test module nis_server
  • Description updated (diff)
  • Status changed from Blocked to Workable
  • Assignee deleted (zluo)

@[y] please look into a workaround, at least early abort as soon as the failure is hit, e.g. in latest test https://openqa.suse.de/tests/1642042 which fails in trying to call "yast2 nfs_server"

#20 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional][y][bsc#1073281]new needles and workaround is needed by test module nis_server to [sle][functional][y][bsc#1073281][easy] new needles and workaround is needed by test module nis_server
  • Difficulty set to easy

#21 Updated by mloviska about 2 years ago

MM test nis_client & nis_server has been fixed since build 581.4
Verification:
SLE15:
sle-15-Installer-DVD-x86_64-Build591.1-nis_client@64bit
sle-15-Installer-DVD-x86_64-Build591.1-nis_server@64bit
SLE12SP4:
sle-12-SP4-Server-DVD-x86_64-Build0236-nis_server@64bit
sle-12-SP4-Server-DVD-x86_64-Build0236-nis_client@64bit

Is there anything else which should be done with the test?

#22 Updated by okurz about 2 years ago

  • Status changed from Workable to Resolved
  • Assignee set to mloviska

great, so I would you say you did it! In case there is anything going on in the two bugs bsc#1083487 or bsc#1090886 then it might be necessary to do more test adaptions. If this is the case and you can not finish it within a short timeframe feel free to create new tickets for planning.

#23 Updated by mloviska about 2 years ago

  • Related to action #35745: [sle][functional][y][bsc#1083487] - Use static port configuration for NIS/NFS instead of disabling firewalld in MM nfs client/server test suites added

#24 Updated by mloviska about 2 years ago

Do we need a ticket for https://bugzilla.suse.com/show_bug.cgi?id=1090886 ? I will be notified by mail automatically.

#25 Updated by okurz about 2 years ago

a bug is a ticket, isn't it? Do you mean if you need a progress ticket to just track the bug? No. As you rightly stated: "will be notified by mail automatically". This is why I stated: "In case there is anything going on in the [bugs] feel free to create new tickets for planning.", but only then.

Also available in: Atom PDF