Project

General

Profile

action #23780

action #23516: [sle][tw][x11regressions] Migrate x11regression cases of SLE to tumbleweed

[tw][desktop] Migrate regression-documentation cases of SLE to Tumbleweed

Added by qkzhu almost 3 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
-
Start date:
2017-08-30
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

We should:

  1. Update the cases
  2. Update main.pm
  3. Create testsuite in o.o.o

testsuite of regression-installation:

BOOTFROM=c
HDD_1=openSUSE-%VERSION%-%BUILD%-%ARCH%_for_regression.qcow2
REGRESSION=documentation
START_AFTER_TEST=regression-installation

Including:

  • x11regressions/gnote/gnote_first_run
  • x11regressions/gnote/gnote_link_note
  • x11regressions/gnote/gnote_rename_title
  • x11regressions/gnote/gnote_undo_redo
  • x11regressions/gnote/gnote_edit_format
  • x11regressions/gnote/gnote_search_all
  • x11regressions/gnote/gnote_search_body
  • x11regressions/gnote/gnote_search_title
  • x11regressions/evince/evince_open
  • x11regressions/evince/evince_view
  • x11regressions/evince/evince_rotate_zoom
  • x11regressions/evince/evince_find
  • x11regressions/gedit/gedit_launch
  • x11regressions/gedit/gedit_save
  • x11regressions/gedit/gedit_about
  • x11regressions/libreoffice/libreoffice_mainmenu_components
  • x11regressions/libreoffice/libreoffice_recent_documents
  • x11regressions/libreoffice/libreoffice_default_theme
  • x11regressions/libreoffice/libreoffice_open_specified_file
  • x11regressions/libreoffice/libreoffice_double_click_file

Except:

x11regressions/libreoffice/libreoffice_mainmenu_favorites (This case is based on SLE-Classic)
x11regressions/evolution/evolution_prepare_servers
x11regressions/libreoffice/libreoffice_pyuno_bridge (o.o.o doesn't have tap worker)


Related issues

Related to openQA Tests - action #40082: [qam] [sle] test fails in gnote_rename_title - needle gnote-new-note-matched seems different than expected after some changesRejected2018-08-21

History

#1 Updated by qkzhu almost 3 years ago

  • Status changed from New to In Progress
  • Assignee set to qkzhu

#2 Updated by qkzhu almost 3 years ago

Port testsuite regression-documentation to Tumbleweed

  • Extract load_x11regression_documentation to main_common
  • Update main.pm of SLE and openSUSE
  • Update 9 cases including gedit, gnote, libreoffice since TW uses the newer version
  • We should also add testsuite of regression-documentation to o3: BOOTFROM=c, DESKTOP=gnome, HDD_1=openSUSE-%VERSION%-%BUILD%-%ARCH%_for_regression.qcow2, REGRESSION=documentation, START_AFTER_TEST=regression-installation

Validation Test: http://10.67.17.30/tests/970
PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3494

#5 Updated by okurz almost 3 years ago

  • Category set to New test

#6 Updated by yfjiang about 2 years ago

  • Assignee changed from qkzhu to GraceWang

Grace, since you've been working on https://progress.opensuse.org/issues/35272 thanks for adding this in the working queue :-)

#7 Updated by yfjiang about 2 years ago

  • Assignee changed from GraceWang to yuanren10

Hi Ray,

Would you take care of this as the next step please :-) Thank you!

#8 Updated by yuanren10 about 2 years ago

Sure. I will take care of that.

#9 Updated by yfjiang about 2 years ago

  • Subject changed from [tw][x11regressions] Migrate regression-documentation cases of SLE to Tumbleweed to [tw][desktop] Migrate regression-documentation cases of SLE to Tumbleweed

#10 Updated by yuanren10 about 2 years ago

Reference:
PR#409
PR#5539

testsuite changed
DESKTOP=gnome
HDD_1=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-%DESKTOP%@%MACHINE%.qcow2
REGRESSION=documentation
START_AFTER_TEST=create_hdd_gnome

Verfication run:
create_hdd_gnome
qam-regression-documentation

#11 Updated by yuanren10 almost 2 years ago

  • Status changed from In Progress to Resolved

#12 Updated by pcervinka almost 2 years ago

  • Related to action #40082: [qam] [sle] test fails in gnote_rename_title - needle gnote-new-note-matched seems different than expected after some changes added

#13 Updated by yfjiang almost 2 years ago

  • Assignee changed from yuanren10 to zgao

Reopen the ticket since Zhiyuan will work on continuous working based on the latest TW and drive it to Tumbleweed job group from the Development job group.

#14 Updated by yfjiang almost 2 years ago

  • Status changed from Resolved to In Progress

#15 Updated by zgao almost 2 years ago

Test suite of regression-documentation should be updated.

New name regression-documentation instead of qam-regression-documentation

#16 Updated by okurz almost 2 years ago

zgao wrote:

Test suite of regression-documentation should be updated.

New name regression-documentation instead of qam-regression-documentation

Be careful. "qam-regression-documentation" might not be the same as regression-documentation as it is used in maintenance/QAM tests

#17 Updated by zgao almost 2 years ago

#18 Updated by zgao over 1 year ago

  • Status changed from In Progress to Resolved

desktopapps-documentation removed from development tumbleweed.

It has passed tests under openSUSE tumbleweed job group on o.o.o

Also available in: Atom PDF