action #17874

test fails with DIE No map for '\r' in VNC.pm

Added by SLindoMansilla about 3 years ago. Updated about 2 years ago.

Status:ResolvedStart date:22/03/2017
Priority:NormalDue date:
Assignee:mitiao% Done:

0%

Category:Concrete Bugs
Target version:Done
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-ppc64le-sdk-http@ppc64le fails in
no_perl_bootloader

DIE No map for '
' at /usr/lib/os-autoinst/consoles/VNC.pm line 735.

 at /usr/lib/os-autoinst/backend/baseclass.pm line 73.
    backend::baseclass::die_handler('No map for \'\x{d}\' at /usr/lib/os-autoinst/consoles/VNC.pm line...') called at /usr/lib/os-autoinst/consoles/VNC.pm line 735
    consoles::VNC::map_and_send_key('consoles::VNC=HASH(0x100373b0430)', '\x{d}') called at /usr/lib/os-autoinst/consoles/vnc_base.pm line 135
    consoles::vnc_base::type_string('consoles::vnc_base=HASH(0x100372e59b0)', 'HASH(0x10037510500)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 521
    backend::baseclass::bouncer('backend::qemu=HASH(0x100370cb8b0)', 'type_string', 'HASH(0x10037510500)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 541
    backend::baseclass::type_string('backend::qemu=HASH(0x100370cb8b0)', 'HASH(0x10037510500)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 68
    backend::baseclass::handle_command('backend::qemu=HASH(0x100370cb8b0)', 'HASH(0x100375104d0)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 422
    backend::baseclass::check_socket('backend::qemu=HASH(0x100370cb8b0)', 'IO::Handle=GLOB(0x100370152a0)') called at /usr/lib/os-autoinst/backend/qemu.pm line 1006
    backend::qemu::check_socket('backend::qemu=HASH(0x100370cb8b0)', 'IO::Handle=GLOB(0x100370152a0)', 0) called at /usr/lib/os-autoinst/backend/baseclass.pm line 203
    eval {...} called at /usr/lib/os-autoinst/backend/baseclass.pm line 151
    backend::baseclass::run_capture_loop('backend::qemu=HASH(0x100370cb8b0)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 122
    backend::baseclass::run('backend::qemu=HASH(0x100370cb8b0)', 6, 9) called at /usr/lib/os-autoinst/backend/driver.pm line 85
    backend::driver::start('backend::driver=HASH(0x1003594c378)') called at /usr/lib/os-autoinst/backend/driver.pm line 48
    backend::driver::new('backend::driver', 'qemu') called at /usr/bin/isotovideo line 198
    main::init_backend() called at /usr/bin/isotovideo line 263

Reproducible

Fails since (at least) Build 0290 (current job)

Expected result

Last good: 0289 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolo about 3 years ago

  • Subject changed from test fails with DIE No map for '\n' in VNC.pm to test fails with DIE No map for '\r' in VNC.pm

if it was \n you wouldn't see the error. The problem is the test typing \r and not \n

#2 Updated by okurz about 3 years ago

  • Category set to Concrete Bugs

#3 Updated by coolo over 2 years ago

  • Target version set to Ready

\r should be ignored IMO - another entrance level issue

#4 Updated by mitiao over 2 years ago

  • Assignee set to mitiao

#5 Updated by mitiao over 2 years ago

  • Status changed from New to In Progress

#6 Updated by mitiao over 2 years ago

  • Status changed from In Progress to Resolved

#7 Updated by szarate about 2 years ago

  • Target version changed from Ready to Done

Also available in: Atom PDF