action #17706

error creating needle "wrong parameters: imageversion"

Added by okurz almost 3 years ago. Updated almost 2 years ago.

Status:ResolvedStart date:14/03/2017
Priority:NormalDue date:
Assignee:dasantiago% Done:

100%

Category:Concrete Bugs
Target version:Done
Difficulty:
Duration:

Description

observation

on o3 in /var/log/openqa.log

[Tue Mar 14 15:47:35 2017] [15628:error] imageversion like 1 (?^:^[^./]+$)

while trying to save needle (see screenshot)

openQA_wrong_imageversion.png (89.4 KB) okurz, 14/03/2017 03:50 pm

2962

History

#1 Updated by coolo over 2 years ago

  • Target version set to Ready

well, you closed #14358 prematurely obviously - but we still don't know what it's triggering

#2 Updated by dasantiago almost 2 years ago

  • Status changed from New to In Progress
  • Assignee set to dasantiago

#3 Updated by dasantiago almost 2 years ago

The problem is with the job's VERSION variable (which is not mandatory and can be set by the tester to anything)

The version is used to know to which folder the needle needs to be saved.

$dir .= "-$version" if $version && -e "$dir-$version";

By default the version is set as empty "", only when someone chooses an image from the drop down list, then the needle will be set the image version.

Example of a current needle with this problem:

https://openqa.suse.de/tests/1044010#step/partitioning/1

choose an different image from the dropdown list: "Take image from" and try to save.

This can be fixed in different ways:
1- Accept dots (.) in the validation but not more than 1 consecutive dot
2- strip all the forbidden chars from the input
2.1- replace the forbiden chars with some default char...
3- dont accept versions with forbidden chars

Currently in openqa everything is a link to the same folder.

#4 Updated by dasantiago almost 2 years ago

  • % Done changed from 0 to 90

went for option 1 since, a dot is a valid character in all the OS (windows, mac and linux).

#5 Updated by dasantiago almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

#6 Updated by EDiGiacinto almost 2 years ago

  • Target version changed from Ready to Current Sprint

#7 Updated by coolo almost 2 years ago

  • Target version changed from Current Sprint to Done

Also available in: Atom PDF