Project

General

Profile

action #16432

[functional][u][medium]test fails in updates_packagekit_kde assuming "install updates" when there are no more

Added by okurz over 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-02-02
Due date:
2018-05-08
% Done:

0%

Estimated time:
Difficulty:
medium
Duration: 329

Description

Observation

openQA test in scenario opensuse-42.3-DVD-x86_64-kde-sddm@64bit fails in
updates_packagekit_kde
looking for "install updates" when "check for updates" is shown.
And leap 15:
https://openqa.opensuse.org/tests/639809

Reproducible

Fails since (at least) Build 0063 (current job)
but I am sure I have seen this in before but being afraid of coolo telling me I file too many tickets I just posted a question in #os-fctry and here we are again…

Expected result

Last good: 0062 (or more recent)

Suggestion

Maybe the test module is too fast looking for any more updates while the applet is not yet updated and then wrongly looks for an install button.

Further details

Always latest result in this scenario: latest
latest leap 15


Related issues

Related to openQA Tests - action #31327: [functional][opensuse][u][sporadic]test fails in updates_packagekit_kde - part 1Resolved2018-02-02

Related to openQA Tests - action #30085: [functional][u][medium] test fails in updates_packagekit_gpk - no restarting packagekit daemon after libzypp updateResolved2018-01-092018-04-10

Related to openQA Tests - action #30811: [opensuse][leap][functional][u]test fails in updates_packagekit_gpk - packagekit to quit not runningResolved2018-01-252018-06-19

History

#2 Updated by okurz over 2 years ago

  • Subject changed from test fails in updates_packagekit_kde assuming "install updates" when there are no more to [functional]test fails in updates_packagekit_kde assuming "install updates" when there are no more
  • Target version set to Milestone 15

#3 Updated by okurz about 2 years ago

  • Due date set to 2018-04-10

#4 Updated by okurz about 2 years ago

  • Related to action #31327: [functional][opensuse][u][sporadic]test fails in updates_packagekit_kde - part 1 added

#5 Updated by riafarov about 2 years ago

  • Related to action #30085: [functional][u][medium] test fails in updates_packagekit_gpk - no restarting packagekit daemon after libzypp update added

#6 Updated by riafarov about 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable

#7 Updated by okurz about 2 years ago

  • Subject changed from [functional]test fails in updates_packagekit_kde assuming "install updates" when there are no more to [functional][u][medium]test fails in updates_packagekit_kde assuming "install updates" when there are no more
  • Due date changed from 2018-04-10 to 2018-05-08

#8 Updated by cwh about 2 years ago

  • Difficulty set to medium

#9 Updated by okurz about 2 years ago

  • Related to action #30811: [opensuse][leap][functional][u]test fails in updates_packagekit_gpk - packagekit to quit not running added

#10 Updated by okurz about 2 years ago

  • Target version changed from Milestone 15 to Milestone 16

correcting milestone

#11 Updated by jorauch about 2 years ago

  • Assignee set to jorauch

#12 Updated by jorauch about 2 years ago

  • Status changed from Workable to In Progress

Might have been fixed in:
https://progress.opensuse.org/issues/31327

Trying to proof this

#13 Updated by jorauch about 2 years ago

  • Status changed from In Progress to Resolved

This seems to be a rare race condition which should have been fixed in:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4433

We have not seen this error since the merge so I close this

Also available in: Atom PDF