Project

General

Profile

Actions

action #150959

closed

coordination #127031: [saga][epic] openQA for SUSE customers

coordination #127028: [epic] openQA on SLE+packagehub

openQA fails to build on SLE/Leap 15.6 Backports due to test-unit-and-integration failures size:M

Added by okurz 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2023-11-16
Due date:
% Done:

0%

Estimated time:

Description

Motivation

os-autoinst+openQA (and dependencies) are in Leap and/or backports repos aka. "SUSE PackageHub". Now for version 15.6 build tests fail for both os-autoinst+openQA, see https://bugzilla.suse.com/show_bug.cgi?id=1217246 and https://bugzilla.suse.com/show_bug.cgi?id=1217249 . Likely we want to support those packages there for the parent #127028 anyway so we should make sure that both bugs are fixed based on whatever the test failures tell us.

Failures seem to be related to spurt deprecation warnings, for example:

    [   96s] 3: Failed 1/9 subtests 
[   96s] 3: [10:40:59] ./20-openqa-benchmark-stopwatch-utils.t .. ok      129 ms ( 0.00 usr  0.00 sys +  0.12 cusr  0.01 csys =  0.13 CPU)
[   96s] 3: Mojo::File::spurt is deprecated in favor of Mojo::File::spew at /home/abuild/rpmbuild/BUILD/os-autoinst-4.6.1639403953.ae94c4bd/bmwqemu.pm line 73.

Acceptance criteria

Suggestions

  • Look into the test failures. As needed reproduce locally in a corresponding environment
  • Fix the build+check, i.e. either fix the tests or exclude irrelevant tests from build time testing
  • Submit according updates to packages as needed to upstream and backport or just backport patches as applicable (create a submit request on build.opensuse.org from the relevant packages from the openSUSE:Factory project to the openSUSE:Backports:SLE-15-SP6 project)
  • See if we need to backport a newer os-autoinst matching the mojo used
  • Maybe it helps to just backport Test::Warnings and our changes to the specfile to disabled treating warnings as errors during builds (PERL_TEST_WARNINGS_ONLY_REPORT_WARNINGS=1). Test::Warnings is in SUSE:SLE-15:Update: https://build.suse.de/request/show/310059 https://progress.opensuse.org/issues/137105#note-29

Related issues 1 (0 open1 closed)

Related to openQA Project - action #137105: Handle Perl deprecation warning messages gracefully (Mojo::File::spurt is deprecated in favor of Mojo::File::spew) size:MResolvedtinita2023-09-272023-12-15

Actions
Actions #1

Updated by okurz 5 months ago

  • Description updated (diff)
  • Parent task set to #127028
Actions #2

Updated by okurz 5 months ago

  • Target version changed from Ready to Tools - Next
Actions #3

Updated by okurz 5 months ago

  • Target version changed from Tools - Next to Ready
Actions #4

Updated by livdywan 5 months ago

  • Subject changed from openQA fails to build on SLE/Leap 15.6 Backports due to test-unit-and-integration failures to openQA fails to build on SLE/Leap 15.6 Backports due to test-unit-and-integration failures size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #5

Updated by tinita 5 months ago

  • Description updated (diff)
Actions #6

Updated by tinita 5 months ago

  • Description updated (diff)
Actions #7

Updated by tinita 5 months ago

  • Related to action #137105: Handle Perl deprecation warning messages gracefully (Mojo::File::spurt is deprecated in favor of Mojo::File::spew) size:M added
Actions #8

Updated by osukup 5 months ago

still waiting on https://maintenance.suse.de/request/311662/ --> after release for 15.4/5 it should be also added into 15.6 by maintenance

Actions #9

Updated by osukup 5 months ago

  • Status changed from Workable to In Progress
  • Assignee set to osukup

update for SLE/Leap 15.4/15.5 was released .. so now sync it into 15.6 and build should pass

Actions #10

Updated by osukup 5 months ago

According to L. Kocman sync from leap 15.4/15.5 updates is manual one time per week, so we need a few days to wait :D

Actions #11

Updated by tinita 5 months ago

I think we would still need to add a patch with PERL_TEST_WARNINGS_ONLY_REPORT_WARNINGS=1 in the specfile, if we don't update openQA itself

Actions #12

Updated by openqa_review 5 months ago

  • Due date set to 2023-12-09

Setting due date based on mean cycle time of SUSE QE Tools

Actions #13

Updated by osukup 5 months ago

sent SR to Leap 15.6 with last version of openQA/os-autoinst

Actions #14

Updated by osukup 5 months ago

https://maintenance.suse.de/incident/30819/ .. this is needed for passing tests on Leap 15.6

Actions #15

Updated by osukup 5 months ago

so ECO for this incident was rejected -> https://jira.suse.com/browse/PED-7023 , so probability to get perl-Test-MockModule into Leap 15.6 is low

--> we have two possible solutions for this on hand now:

1) disable tests in openQA/os-autoinst spec on official Leap 15.6 package
2) drop os-autoinst/openQA from official Leap repo

second solution will be in line what we now recommends for users now -> using devel:openQA and devel:openQA:Leap:15.6 repo as official and only way to install openQA on openSUSE Leap

Actions #16

Updated by okurz 5 months ago

Well, disabling individual tests is fine. What's with #150959-11 ?

Actions #17

Updated by osukup 5 months ago

@okurz I submitted newer version of os-autoinst and openQA into Leap 15.6 ... so they have this var set. And then we hit problem with perl-Test-MockModule :(

I enabled Leap 15.6 in devel:openQA and linked perl-Test-MockModule into devel:openQA:Leap:15.6 , and everything build fine ..

Actions #18

Updated by osukup 5 months ago

hmm , @lkocman offered possibility to fork perl-Test-MockModule in Leap15.6 :D

Actions #20

Updated by osukup 5 months ago

  • Status changed from In Progress to Blocked

waiting for Backport Team to merge MR on gitlab, i'll try ping Scot Bahling or BigIronMan ..

Actions #21

Updated by osukup 5 months ago

osukup wrote in #note-20:

waiting for Backport Team to merge MR on gitlab, I'll try to ping Scot Bahling or BigIronMan ..

should be merged today or tomorrow - 6-7.12.2023

Actions #22

Updated by osukup 5 months ago

MR merged,

created SR for perl-Test-MockModule and others from rejected Incident :D Asked Max Lin to override factory-auto reject.

https://build.opensuse.org/request/show/1131339
https://build.opensuse.org/request/show/1131338
https://build.opensuse.org/request/show/1131337
https://build.opensuse.org/request/show/1131336

Actions #23

Updated by osukup 5 months ago

  • Status changed from Blocked to In Progress

saging:6 is green --> accepted to Leap 15.6

Actions #24

Updated by osukup 5 months ago

and new PED -> https://jira.suse.com/browse/PED-7020

it looks like in the end it will also get into SLE-15-SP6

Actions #25

Updated by okurz 4 months ago

  • Due date deleted (2023-12-09)
  • Status changed from In Progress to Workable

@osukup so what's your next steps planned, wait for https://jira.suse.com/browse/PED-7020 to be accepted and complete?

Actions #26

Updated by osukup 4 months ago

  • Status changed from Workable to Resolved

okurz wrote in #note-25:

@osukup so what's your next steps planned, wait for https://jira.suse.com/browse/PED-7020 to be accepted and complete?

I think we can resolve this POO as is about building openQA/os-autoinst on Leap 15.6 and AC1 is fullfilled

there should be poo about openQA on SLE?

  • We should send an update into Leap 15.6 until beta 2 ( when it will be locked ..)
Actions #27

Updated by okurz 4 months ago

osukup wrote in #note-26:

okurz wrote in #note-25:

@osukup so what's your next steps planned, wait for https://jira.suse.com/browse/PED-7020 to be accepted and complete?

I think we can resolve this POO as is about building openQA/os-autoinst on Leap 15.6 and AC1 is fullfilled

there should be poo about openQA on SLE?

yes, there is, it's covered by the parent. I agree to have this ticket resolved.

  • We should send an update into Leap 15.6 until beta 2 ( when it will be locked ..)

Yes, I would do that after #127541 which is currently in the backlog.

Actions

Also available in: Atom PDF