Project

General

Profile

Actions

action #135914

closed

coordination #112862: [saga][epic] Future ideas for easy multi-machine handling: MM-tests as first-class citizens

coordination #111929: [epic] Stable multi-machine tests covering multiple physical workers

Extend/add initial validation steps and "best practices" for multi-machine test setup/debugging to openQA documentation size:M

Added by okurz 10 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Motivation

In #134282 we have collected many good ideas what one can do to investigate for multi-machine test issues. To make sure this is not forgotten we should collect those ideas and add them as "best practices" as applicable in openQA documentation.

Acceptance criteria

Suggestions

  • Look into http://open.qa/docs , http://open.qa/docs/#_debugging_open_vswitch_configuration and see what is already there regarding multi-machine setup and debugging hints
  • Go through all comments of #134282 and collect what could be used in general, at least
    • minimal reproducer scenarios
    • basic linux configuration to check, e.g. sysctl forwarding parameters
    • ping checks, including multiple packet sizes
  • Try improving how the documentation is structured

Related issues 1 (0 open1 closed)

Copied from openQA Infrastructure - action #134282: [tools] network protocols failures on multimachine tests on HA/SAP size:S auto_review:"no candidate.*iscsi-target-overview-service-tab|yast2.+firewall.+services.+add.+zone":retryResolvednicksinger2023-08-15

Actions
Actions #1

Updated by okurz 10 months ago

  • Copied from action #134282: [tools] network protocols failures on multimachine tests on HA/SAP size:S auto_review:"no candidate.*iscsi-target-overview-service-tab|yast2.+firewall.+services.+add.+zone":retry added
Actions #2

Updated by okurz 8 months ago

  • Description updated (diff)
Actions #3

Updated by okurz 8 months ago

  • Target version changed from Tools - Next to Ready
Actions #4

Updated by okurz 8 months ago

  • Parent task set to #111929
Actions #5

Updated by jbaier_cz 8 months ago

  • Description updated (diff)
Actions #6

Updated by tinita 8 months ago

  • Subject changed from Extend/add initial validation steps and "best practices" for multi-machine test setup/debugging to openQA documentation to Extend/add initial validation steps and "best practices" for multi-machine test setup/debugging to openQA documentation size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #7

Updated by okurz 6 months ago

exceeded SLO mostly due to vacation absence, second chance :)

Actions #8

Updated by mkittler 6 months ago

  • Status changed from Workable to In Progress
  • Assignee set to mkittler
Actions #9

Updated by mkittler 6 months ago

  • Status changed from In Progress to Feedback

I created https://github.com/os-autoinst/openQA/pull/5432 to update the documentation where things are missing or outdated.

The overall structure has already been improved via 949e7fef5b84b3feb5130e002ba71c1b27289357 and with 23ec4a97b27fd77dc3ad23a1b1b5fec07ff4290b, e55ef32ae63fc44483efe35b31bd0554945ae8d2 and 96783eefce6dcf53560737a7ba26650752e7347c we have already improved several aspects.

Actions #10

Updated by mkittler 6 months ago

  • Status changed from Feedback to Resolved

The PR has been merged and with that I think everything is covered.

Actions

Also available in: Atom PDF