Project

General

Profile

Actions

action #134600

closed

[OSD] Figure out that some 64bit-ipmi workers change to iPXE bootmod size:M

Added by xguo 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Support
Target version:
Start date:
2023-08-24
Due date:
% Done:

0%

Estimated time:

Description

Motivation

Today, figure out the following OSD test worker changed to iPXE bootmod. Depend on the current situation block our PR validation run.

#grenache-1:12 - kermit.qa.suse.de

#grenache-1:13 - gonzo.qa.suse.de

#grenache-1:14 - fozzie.qa.suse.de

#grenache-1:15 - scooter.qa.suse.de

Suggestions

  • Help the OP change the above OSD worker back to PXE bootmod
  • As needed consider any remaining changes to the new menu to make it work in all cases

Files

Actions #2

Updated by nicksinger 6 months ago

Yes, this is the new PXE boot menu. Why is it blocking your tests? Do the entries not work for you?

Actions #3

Updated by xguo 6 months ago

nicksinger wrote in #note-2:

Yes, this is the new PXE boot menu. Why is it blocking your tests? Do the entries not work for you?

@Nick
yes, our current automation test run still use with old PXE boot menu. Meanwhile, our existed automation test run do not support this NEW PXE boot menu. Also, confirm that this new PXE boot menu does not work with us.

Would you mind helping us change them (or 2 SUT) back to Old PXE boot menu. thanks

Actions #4

Updated by tinita 6 months ago

  • Target version set to Ready
Actions #5

Updated by livdywan 6 months ago

  • Status changed from New to Feedback
  • Assignee set to livdywan

@xguo I'm not clear what you mean when you state your tests don't support the new PXE boot menu. Do you have any example jobs?

Actions #6

Updated by xguo 6 months ago

livdywan wrote in #note-5:

@xguo I'm not clear what you mean when you state your tests don't support the new PXE boot menu. Do you have any example jobs?

@livdywan Current our osd automation test runs work with the old PXE boot menu from the attached screenshot.

Meanwhile, please refer to test url - https://openqa.suse.de/tests/11404824#step/boot_from_pxe/2 for getting more details. thanks

Actions #7

Updated by okurz 6 months ago

https://openqa.suse.de/tests/11404824#step/boot_from_pxe/2 shows a passed test.

Another example of how a test expecting iPXE can work is
https://openqa.suse.de/tests/11859862#step/boot_from_pxe/5
just for your plans that you should consider to support iPXE as well.

Can you please reference a URL to a recent test failure from a reproducing scenario?

Actions #8

Updated by dheidler 6 months ago

The boot_from_pxe module already supports the iPXE setup and automatically acts accordingly if the iPXE menu is detected via needle matching.

iPXE supports UEFI booting and HTTPBoot on both x86_64 and aarch64 while the old pxelinux doesn't.
So you can expect pxelinux to die out eventually.

This is how the module was updated to support iPXE:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/17588/files

Actions #9

Updated by dheidler 6 months ago

@xguo
Seems that the test referenced by you runs fine using iPXE:
https://openqa.suse.de/tests/11949653#step/boot_from_pxe/2

Actions #10

Updated by xguo 6 months ago

Refer to the latest test results of SLES15SP6 build16.1, figure out some test still block by new iPXE boot
https://openqa.suse.de/tests/11961115#step/boot_from_pxe/13

Actions #12

Updated by livdywan 6 months ago

  • Subject changed from [OSD] Figure out that some 64bit-ipmi workers change to iPXE bootmod to [OSD] Figure out that some 64bit-ipmi workers change to iPXE bootmod size:M
  • Description updated (diff)
Actions #13

Updated by dheidler 6 months ago

  • Assignee changed from livdywan to dheidler

The test at https://openqa.suse.de/tests/11961115#step/boot_from_pxe/13 failed, because someone created a needle, with the wrong tags.
Deleted that needle: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/-/commit/1087c3c043d61f80a784f321998f4fb0ae7fd931
Created proper needle: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/-/commit/b9b9db6258fc7e9a7b2a108f136f29172a2fd86a
The tag nue-ipxe-menu is used to detect that the iPXE menu is seen.

Verification: https://openqa.suse.de/tests/11963736

Actions #14

Updated by xguo 6 months ago

dheidler wrote in #note-13:

The test at https://openqa.suse.de/tests/11961115#step/boot_from_pxe/13 failed, because someone created a needle, with the wrong tags.
Deleted that needle: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/-/commit/1087c3c043d61f80a784f321998f4fb0ae7fd931
Created proper needle: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/-/commit/b9b9db6258fc7e9a7b2a108f136f29172a2fd86a
The tag nue-ipxe-menu is used to detect that the iPXE menu is seen.

Verification: https://openqa.suse.de/tests/11963736

@dheidler

Awesome! Thanks so much for your great help.

Actions #15

Updated by livdywan 6 months ago

  • Status changed from Feedback to Resolved

As per the above verification runs we seem to be good here.

Actions

Also available in: Atom PDF