Project

General

Profile

Actions

action #132671

closed

QA - coordination #121720: [saga][epic] Migration to QE setup in PRG2+NUE3 while ensuring availability

QA - coordination #130955: [epic] Migration out of SUSE NUE1 - QE setup in NUE3

Ensure everybody in SUSE QE Tools knows how to access netbox size:M

Added by livdywan 11 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2023-07-07
Due date:
% Done:

0%

Estimated time:

Description

Motivation

We have several tickets which reference netbox for crucial information. Those can't be estimated or worked on if most of the team has no access to the information.

Acceptance criteria

  • AC1: The majority of SUSE QE Tools knows to login to and look up information on netbox

Suggestions

Actions #1

Updated by livdywan 11 months ago

I tried to open netbox w/ tags from one of the server move tickets and after using IDP credentials what I got is this:

You do not have permission to access this page.

@okurz suggests this may be the way to do it, since it should cause a request for approval to be sent out. Will report back.

Actions #2

Updated by openqa_review 11 months ago

  • Due date set to 2023-07-28

Setting due date based on mean cycle time of SUSE QE Tools

Actions #3

Updated by okurz 11 months ago

  • Parent task set to #130955
Actions #4

Updated by tinita 11 months ago

I'm able to access it and look at openqaworker20 for example

Actions #5

Updated by livdywan 11 months ago

I learnt that asking Hannes Reinecke to get access might be the workflow for now, so I will try that and document it appropriately if it works for me.

Actions #6

Updated by livdywan 11 months ago

  • Status changed from In Progress to Feedback

cdywan wrote:

I learnt that asking Hannes Reinecke to get access might be the workflow for now, so I will try that and document it appropriately if it works for me.

I'm able to see items on queries like this one now. Instead of empty sections and padlocks. I updated the onboarding steps on our team wiki page accordingly. I plan to resolve after informing the team and checking that at least one more person can request access.

Actions #7

Updated by okurz 11 months ago

I also updated https://progress.opensuse.org/projects/qa/wiki/Tools#Onboarding-for-new-joiners as now nicksinger and me also have permissions to add you to according groups.

Actions #8

Updated by livdywan 11 months ago

  • Status changed from Feedback to Blocked

okurz wrote:

I also updated https://progress.opensuse.org/projects/qa/wiki/Tools#Onboarding-for-new-joiners as now nicksinger and me also have permissions to add you to according groups.

Thanks!

@osukup was able to create an account and got added. For @kraih I filed an SD ticket since there's something else that's broken, so I would block the ticket on that and resolve it once that's handled.

Actions #9

Updated by kraih 11 months ago

Result for user "kraih" when logging in via openSUSE SSO:

Server Error

There was a problem with your request. Please contact an administrator.

The complete exception is provided below:

<class 'social_core.exceptions.AuthForbidden'>

Your credentials aren't allowed

Python version: 3.10.6
NetBox version: 3.3.7

If further assistance is required, please post to the NetBox discussion forum on GitHub.
Actions #10

Updated by okurz 11 months ago

  • Due date deleted (2023-07-28)

removing due-date as unfortunately https://sd.suse.com/servicedesk/customer/portal/1/SD-127864 is still open but this ticket here is not that time critical so ok to keep in "Blocked" with "Normal" prio

Actions #11

Updated by livdywan 10 months ago

  • Status changed from Blocked to Feedback

I'm taking this back to Feedback. @kraih's ticket is still open. Also I lost access and apparently none of our documented points of contact is around this week. We should improve on the bus factor.

For now I'm asking Hannes again.

Actions #12

Updated by livdywan 10 months ago

For now I'm asking Hannes again.

Got my access back!

Actions #13

Updated by livdywan 10 months ago

okurz wrote in #note-10:

removing due-date as unfortunately https://sd.suse.com/servicedesk/customer/portal/1/SD-127864 is still open but this ticket here is not that time critical so ok to keep in "Blocked" with "Normal" prio

Still trying to get Sebastian's account to work. Also asked Hannes in Slack.

Actions #14

Updated by livdywan 10 months ago

  • Subject changed from Ensure everybody in SUSE QE Tools knows how to access netbox to Ensure everybody in SUSE QE Tools knows how to access netbox size:M
Actions #15

Updated by livdywan 9 months ago

https://sd.suse.com/servicedesk/customer/portal/1/SD-127864 is progressing. Apparently there's 3 different accounts in the system. To be confirmed if one of them can be used.

Actions #16

Updated by okurz 9 months ago

  • Status changed from Feedback to Workable

@kraih please try to login. And hreinecke asked to create "another issue to fix $something"

Actions #17

Updated by okurz 9 months ago

  • Status changed from Workable to Resolved

Last comment in SD ticket was from Sebastian Riedel

Thanks, i can now log in and see everything.

after 2 months that must now suffice.

Actions

Also available in: Atom PDF