Project

General

Profile

Actions

action #130369

closed

coordination #154777: [saga][epic] Shareable os-autoinst and test distribution plugins

coordination #108527: [epic] os-autoinst wheels for scalable code reuse of helper functions and segmented test distributions

[spike][timeboxed:20h] Reduce duplication of openQA-in-openQA tests in os-autoinst-distri-opensuse and os-autoinst-distri-openQA size:S

Added by okurz 11 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Feature requests
Target version:
Start date:
2023-06-01
Due date:
% Done:

0%

Estimated time:

Description

Motivation

https://github.com/os-autoinst/os-autoinst-distri-opensuse/tree/master/tests/openqa started mostly as a "copy&paste" variant of https://github.com/os-autoinst/os-autoinst-distri-openQA/ as commented in
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6595#pullrequestreview-194607032 . Recent incidents like #130201 show that we suffer from "I thought we fixed this bug already!"-problems recurringly, … who would have thought that? Let's try to evaluate what options we have regarding enfostering reuse of code, maybe use wheels here as well?

Suggestions


Related issues 5 (1 open4 closed)

Related to openQA Project - action #127286: Run openQA (webUI+worker) based on SLE+packagehub size:MBlockedjbaier_cz2023-03-31

Actions
Copied from openQA Infrastructure - action #130201: openqa_bootstrap: fetchneedles not called during openqa-bootstrap size:SResolvedjbaier_cz2023-06-01

Actions
Copied to openQA Project - action #132335: In openqa-in-openqa use scenario definitions instead of job group templates size:MResolvedosukup2023-06-01

Actions
Copied to openQA Project - action #134390: Log proactively where wheel components are located to ease debugging size:MResolvedlivdywan2023-06-01

Actions
Copied to openQA Project - action #138032: Find out most/least used testapi functions to decide about where to extend/cleanup size:MResolvedjbaier_cz

Actions
Actions #1

Updated by okurz 11 months ago

  • Copied from action #130201: openqa_bootstrap: fetchneedles not called during openqa-bootstrap size:S added
Actions #2

Updated by jbaier_cz 11 months ago

Optional: Find out why #130201 was hit in openSUSE Tumbleweed and not already in https://openqa.opensuse.org/group_overview/24 and if possible fix that from happening again in the future

TW in #130201 uses openqa_bootstrap script to install openQA, however openQA-in-openQA does not

Actions #3

Updated by jbaier_cz 11 months ago

  • Related to action #127286: Run openQA (webUI+worker) based on SLE+packagehub size:M added
Actions #4

Updated by jbaier_cz 11 months ago

Related, but not exactly removing the duplication (yet): https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/116

Actions #5

Updated by okurz 10 months ago

  • Subject changed from [spike][timeboxed:20h] Reduce duplication of openQA-in-openQA tests in os-autoinst-distri-opensuse and os-autoinst-distri-openQA to [spike][timeboxed:20h] Reduce duplication of openQA-in-openQA tests in os-autoinst-distri-opensuse and os-autoinst-distri-openQA size:S
  • Status changed from New to Workable
Actions #6

Updated by okurz 10 months ago

  • Copied to action #132335: In openqa-in-openqa use scenario definitions instead of job group templates size:M added
Actions #7

Updated by okurz 10 months ago

  • Priority changed from Normal to High
Actions #8

Updated by livdywan 8 months ago

  • Copied to action #134390: Log proactively where wheel components are located to ease debugging size:M added
Actions #9

Updated by tinita 8 months ago

  • Status changed from Workable to In Progress
  • Assignee set to tinita

We worked on this in our mob session today. I will commit the current state to a branch in distri-openQA and distri-opensuse

Actions #10

Updated by openqa_review 8 months ago

  • Due date set to 2023-09-01

Setting due date based on mean cycle time of SUSE QE Tools

Actions #11

Updated by tinita 8 months ago

  • Status changed from In Progress to Workable

Setting back to workable for now.
I wasn't able to commit anything because we mainly figured out in the mob session how to work with a local wheels directory, and there were other urgent tasks.

Actions #12

Updated by okurz 8 months ago

  • Due date deleted (2023-09-01)
Actions #13

Updated by tinita 8 months ago

  • Status changed from Workable to Blocked
Actions #14

Updated by tinita 8 months ago

Blocked on #134390

Actions #15

Updated by livdywan 7 months ago

  • Status changed from Blocked to Workable

tinita wrote in #note-14:

Blocked on #134390

Not blocked anymore!

Actions #16

Updated by tinita 7 months ago

  • Status changed from Workable to In Progress
Actions #17

Updated by openqa_review 7 months ago

  • Due date set to 2023-10-17

Setting due date based on mean cycle time of SUSE QE Tools

Actions #18

Updated by tinita 7 months ago

https://github.com/os-autoinst/os-autoinst/pull/2371 Error on non-existing WHEELS_DIR (merged)

Actions #19

Updated by tinita 7 months ago

  • Status changed from In Progress to Workable

Can't work on two tickets at a time

Actions #20

Updated by tinita 7 months ago

  • Status changed from Workable to In Progress
Actions #21

Updated by tinita 7 months ago

Actions #23

Updated by okurz 6 months ago

  • Due date deleted (2023-10-17)
  • Status changed from In Progress to Resolved

We looked at the current situation and approach together in the tools team daily 2023-10-16 and confirmed that our design of wheels is a good way to go. We have not identified any function that should really be in the testapi directly. Continuing in #138029

Actions #24

Updated by okurz 6 months ago

  • Copied to action #138032: Find out most/least used testapi functions to decide about where to extend/cleanup size:M added
Actions

Also available in: Atom PDF