Project

General

Profile

action #12982

What are typed by type_string on ipmi physical machine is not correct.

Added by xlai almost 6 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2016-08-02
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Job link: https://openqa.suse.de/tests/overview?distri=sle&version=12-SP2&build=2016&groupid=46

Testsuites:

*gi-guest_sles12sp2-on-host_sles12sp2-kvm:

Fail stage: host installation
Fail reason: what are typed out by type_string is not complete
At the last step of installation , 'install and reboot', command 'save_y2logs /tmp/y2logs.tar.bz2 ' is typed to 'save_y2lgs /tmp/y2logs.tar.bz2' which results to 'command y2lgs not found' and exit

Also failed for the similar reason in following build tests.


Related issues

Related to openQA Tests - action #12968: yast2_lan test refactorResolved2016-08-01

Blocked by openQA Tests - action #12926: Can not get ipmi serial output correctly.Resolved2016-07-29

History

#1 Updated by xlai almost 6 years ago

The type speed is already the max interval, but still type wrong.

#2 Updated by okurz almost 6 years ago

Looking at https://openqa.suse.de/tests/491232#step/install_and_reboot/4 I see the failure but also in the previous command it typed 'cattt' instead of 'cat'. I think the IPMI backend is at fault in this case. Either IPMI itself or the backend implementation in os-autoinst.

#3 Updated by xlai almost 6 years ago

The issue has been happening in all recent builds.

#4 Updated by okurz almost 6 years ago

  • Assignee set to xlai

xlai, can you further investigate or delegate to someone who could check if IPMI is broken, outdated firmware or other ideas?

#5 Updated by xlai almost 6 years ago

I used to open a issue for os-autoinst about this problem https://github.com/os-autoinst/os-autoinst/issues/555, but kulow closed it. And he also claims that the keyboard driver for ipmi is buggy. I think this is the root cause. So I do not think it can be fixed unless supermicro ipmi fixes the buggy problem.
I know that the firmware of ipmi is outdated in nuremburg, however our beijing machines are the latest, it also has ipmi issue that the serial console connection usually breaks. SO I do not think upgrading the firmware can fix the problem.

I have also talked about it with kulow and my manager calen. There will be some discussion at manager level.

#6 Updated by okurz almost 6 years ago

Thanks for the fast answer.

From your github ticket as reference - Typical failure links:
https://openqa.suse.de/tests/497262#step/skip_registration/6
https://openqa.suse.de/tests/overview?distri=sle&version=12-SP2&build=2016&groupid=46

Can you think of a workaround within os-autoinst to detect this?

#7 Updated by xlai almost 6 years ago

What's the usage of detecting it? Retype again when detecting typing error? Even with this, there must be maximum try times set, but still can not ensure it is correct before final retyping.

#8 Updated by okurz almost 6 years ago

Yes, exactly what you wrote. Something like

  • try typing
  • if wrong, try again up to 7 times
  • if still fails for 7 times, abort

The challenging part would be to detect errors in typing. I am thinking of calling the last command typed with script_output and checking against expected. With fc -n -l -1 one could read the last command executed. This could be compared against what was requested to be typed. If it differs, try again.

#9 Updated by okurz almost 6 years ago

  • Blocked by action #12926: Can not get ipmi serial output correctly. added

#10 Updated by dgutu almost 6 years ago

#11 Updated by dgutu almost 6 years ago

  • Status changed from New to Closed

My position was correct, the problem is not the testcase but something in the IPMI backend.
Closing as the related one is more relevant.

#12 Updated by dgutu almost 6 years ago

  • Is duplicate of deleted (action #12968: yast2_lan test refactor)

#13 Updated by dgutu almost 6 years ago

#14 Updated by RBrownSUSE almost 6 years ago

  • Status changed from Closed to New

Re-opening

#15 Updated by okurz over 5 years ago

  • Category set to Bugs in existing tests

#16 Updated by xlai over 5 years ago

  • Status changed from New to Closed

This is because the ipmi keyboard driver does not work stablely under high pressure. We have tried to decrease the pressure as much as possible in our tests, but it is still not completely avoidable.
So close it.

#17 Updated by okurz over 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: gi-guest_sles12sp1-on-host_sles12sp3-kvm
http://openqa.suse.de/tests/790299

#18 Updated by okurz over 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: gi-guest_sles12sp1-on-host_sles12sp3-kvm
http://openqa.suse.de/tests/790299

#19 Updated by okurz about 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virt-pvusb-sles12sp1-pv-on-sles12sp3-xen
https://openqa.suse.de/tests/873791

Also available in: Atom PDF