Project

General

Profile

Actions

action #128678

closed

raid_gpt: do not ask for the chunk

Added by dimstar about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
2023-05-04
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA needs to go hand-in-hand with a change in yast2-storage-ng:

+- Partitioner: when creating an MD RAID, do not ask for the chunk

  • side when it makes no sense. Eg. RAID1 (bsc#1205172).

With this change, the test fails in staging as below:

openQA test in scenario opensuse-Staging:K-Staging-DVD-x86_64-RAID1_gpt@64bit fails in
raid_gpt

Test suite description

Reproducible

Fails since (at least) Build K.406.2 (current job)

Expected result

Last good: K.406.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to qe-yam - action #128609: Adapt raid_gpt to not expect chunk size screenResolvedsyrianidou_sofia2023-05-03

Actions
Actions #1

Updated by maritawerner about 1 year ago

  • Project changed from openQA Tests to qe-yam
  • Category deleted (Bugs in existing tests)
Actions #2

Updated by JERiveraMoya about 1 year ago

  • Related to action #128609: Adapt raid_gpt to not expect chunk size screen added
Actions #3

Updated by JERiveraMoya about 1 year ago

  • Assignee set to JERiveraMoya
Actions #5

Updated by syrianidou_sofia about 1 year ago

There is a separate schedule for opensuse Leap that is used for staging tests as well. If we see this failure on Tumbleweeb, we will again use one common schedule for all opensuse tests (The correct one would be schedule/yast/opensuse/raid/raid1_gpt_leap.yaml )

Actions #6

Updated by syrianidou_sofia about 1 year ago

After the above merge, tumbleweed lvm+raid1 was failing because it's using sle15sp5 test_data. Adding for fix:
https://github.com/os-autoinst/opensuse-jobgroups/pull/324
and
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/17034

also the following can be reverted and we can use a single schedule and common test_Data with sle again after the update will be implemented on TW
https://github.com/os-autoinst/opensuse-jobgroups/pull/323
https://github.com/os-autoinst/opensuse-jobgroups/pull/322
https://github.com/os-autoinst/opensuse-jobgroups/pull/321

Actions #7

Updated by syrianidou_sofia about 1 year ago

The update is applied for Tumbleweed as well, so I am reverting the changes for separate schedule and test data between Leap, Staging and Tumbleweed
https://suse.slack.com/archives/C02CANHLANP/p1683787632986789?thread_ts=1683703164.768919&cid=C02CANHLANP

on openqa test code repo os-autoinst/os-autoinst-distri-opensuse

on o3 jobgroups repo os-autoinst/opensuse-jobgroups

Actions #8

Updated by JERiveraMoya 12 months ago

  • Status changed from New to Resolved
  • Assignee changed from JERiveraMoya to syrianidou_sofia
Actions

Also available in: Atom PDF