Project

General

Profile

Actions

action #127280

closed

Force_result comment cannot be added on a cancelled child job size:M

Added by vsvecova about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Feature requests
Target version:
Start date:
2023-04-05
Due date:
% Done:

0%

Estimated time:

Description

I tried to add a force_result comment on a child job (with cancelled status) dependent on another job (with failed status) where a force_result comment had already been added:
https://openqa.suse.de/tests/10826620

Upon submitting the comment, I received an error pop-up saying The comment couldn't be added: Bad Request (screenshot added).

I tried adding a regular comment and subsequently editing it to a force_result pattern. The regular comment could be added fine, but the edit did not go through, with the same error.

I do not have enough data to tell whether this is happening consistently. I had previously been able to add a force_result comment on dependent jobs, but cannot recall whether/how they were child-parent linked.


Files


Related issues 1 (0 open1 closed)

Related to openQA Project - action #101716: Improve error reporting for invalid "force_result" commentsResolvedmkittler

Actions
Actions #1

Updated by okurz about 1 year ago

  • Project changed from QA to openQA Project
  • Status changed from New to Feedback
  • Assignee set to okurz
  • Target version set to Ready

I am pretty sure that the force_result comments only work on complete jobs, not jobs that never finished at all

Actions #2

Updated by mkittler about 1 year ago

Steps to reproduce:

  1. Open https://openqa.suse.de/tests/10826620
  2. Add comment label:force_result:softfailed

One only gets the alert as mentioned in the description. The web dev tools reveal a better error message: force_result only allowed on finished jobs

So this is supposedly simply because it is a cancelled job and not a "done" job (and has nothing to do with the child-relation).

Actions #3

Updated by mkittler about 1 year ago

@okurz Ok, so should we allow it for cancelled jobs as well?

I'll improve the error message (so the alert contains the message shown in the dev tools as well). This shouldn't take long.

Actions #4

Updated by vsvecova about 1 year ago

It would be helpful to have a way to ignore cancelled jobs (for the purposes of qam-openqa review) as well, if it's technically possible. When a chained job fails and the linked jobs are cancelled as a result, it doesn't help to add a force_result on the failed job only; the cancelled jobs still block the approval.

Actions #5

Updated by mkittler about 1 year ago

It is definitely technically possible. The question is just whether we want it. When @okurz introduced the feature he explicitly added those checks.


PR for improving the error handling as mentioned: https://github.com/os-autoinst/openQA/pull/5074

Actions #6

Updated by tinita about 1 year ago

  • Related to action #101716: Improve error reporting for invalid "force_result" comments added
Actions #7

Updated by okurz about 1 year ago

  • Category set to Feature requests
  • Status changed from Feedback to New
  • Assignee deleted (okurz)
  • Priority changed from Normal to Low
  • Target version changed from Ready to future

mkittler wrote:

It is definitely technically possible. The question is just whether we want it. When @okurz introduced the feature he explicitly added those checks.

I think I only initially supported finished jobs as that is easier to support and has less implications. I guess by now we can extend to cover not finished jobs as well. One can have big impact with forcing results but now it's in the responsibility of the reviewers and fully traceable so I agree that we should add the support. But not right now due to backlog constraints.

Actions #8

Updated by mkittler 10 months ago

  • Assignee set to mkittler

This has recently come up again twice so I'll take the liberty and have a quick look at it. Presumably it won't take long to implement this.

Actions #9

Updated by mkittler 10 months ago

  • Status changed from New to In Progress
  • Target version changed from future to Ready
Actions #10

Updated by livdywan 10 months ago

  • Subject changed from Force_result comment cannot be added on a cancelled child job to Force_result comment cannot be added on a cancelled child job size:M
  • Status changed from In Progress to Feedback
Actions #11

Updated by okurz 10 months ago

  • Status changed from Feedback to Resolved

PR merged. Deployed on OSD and effective.

Actions

Also available in: Atom PDF