Project

General

Profile

Actions

action #126623

closed

Tags can't coexist with builds that contain colons size:M

Added by szarate about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2023-03-24
Due date:
% Done:

0%

Estimated time:
Tags:

Description

Observation

If a build has the following format: 2023-03-24 14:33:39+01:00 when creating a tag, the webui doesn't allow the tagging

date --rfc-3339=seconds
2023-03-24 14:33:39+01:00

Expected result:

  1. A message is returned to the user when the syntax is invalid
  2. If BUILD can be anything, tag/labels should allow the user to use i.e tag:"2023-03-24 14:33:39+01:00":likethis either via webui or via api

Acceptance Criteria

  • AC1: Tags not matching builds yield clear user feedback
  • AC2: Tags with special characters like : can be used if quoted
  • AC3: Intended, not-matching build tags can still be created, e.g. for a build that will come in some hours

Suggestions

  • Colons are common in build names in some use cases and should be allowed, provide a mean to escape colons
  • Compare to the yellow highlighting we use for labels, highlight for tags that already matches at least one present build
Actions #1

Updated by okurz about 1 year ago

  • Target version set to Ready
Actions #2

Updated by livdywan about 1 year ago

  • Subject changed from Tags can't coexist with builds that contain semicolons to Tags can't coexist with builds that contain semicolons size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #3

Updated by okurz about 1 year ago

  • Priority changed from Normal to Low
Actions #4

Updated by osukup about 1 year ago

  • Assignee set to osukup
Actions #5

Updated by osukup about 1 year ago

  • Subject changed from Tags can't coexist with builds that contain semicolons size:M to Tags can't coexist with builds that contain colons size:M
  • Status changed from Workable to In Progress

problem with colon is caused by usage of colon as delimiter :(

https://github.com/os-autoinst/openQA/blob/master/lib/OpenQA/Schema/Result/Comments.pm#L127-L138

Actions #7

Updated by osukup about 1 year ago

  • Status changed from In Progress to Resolved

merged,

Actions

Also available in: Atom PDF