Project

General

Profile

action #12118

Normal users can not post any comments anymore at all

Added by okurz almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Feature requests
Target version:
-
Start date:
2016-05-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

observation

A normal user (not operator/admin) on o.s.d as well as o3 can not add any comment anymore at all, e.g. on https://openqa.opensuse.org/tests/122287#comments

steps to reproduce

problem

This definitely worked before so it is either an ill-communicated decision or a regression. I did not see any log output on o3 when trying to add a comment.

suggestion

Maybe oholecek knows something about this.
Or try to reproduce manually with debug messages enabled.


Related issues

Has duplicate openQA Project - action #12104: A user without explicit role can not add comments on openQARejected2016-05-24

History

#1 Updated by mkittler almost 6 years ago

I can reproduce this. I'll check my commits for editable comments for relevant changes causing this bug. The group overview is not affected: https://openqa.opensuse.org/group_overview/2

EDIT: Seems like my changes haven't been merged yet so they can not be the source of the issue.

#2 Updated by coolo almost 6 years ago

  • Assignee changed from oholecek to mkittler
  • Priority changed from Urgent to Normal

This never worked, we just didn't notice.

https://github.com/os-autoinst/openQA/pull/710 fixes the problem, but we need more test coverage now. Marius wanted to test this anyway, but couldn't as the fake auth didn't support it - it does now in 710

#3 Updated by okurz almost 6 years ago

  • Assignee changed from mkittler to okurz

I am pretty sure it worked in before, also see https://openqa.opensuse.org/group_overview/1 . I added the corresponding tests now, see https://github.com/os-autoinst/openQA/pull/712

#4 Updated by okurz almost 6 years ago

  • Has duplicate action #12104: A user without explicit role can not add comments on openQA added

#5 Updated by okurz almost 6 years ago

  • Status changed from New to Resolved
  • Priority changed from Normal to High

PR merged, expected to be fixed

#6 Updated by coolo almost 6 years ago

Just for the record: "normal" users were never able to comment to tests - while they always were able to comment in groups. Nothing changed since the original implementation of comments - just noone tried to comment tests before the information got used for labels

Also available in: Atom PDF