Project

General

Profile

action #12104

A user without explicit role can not add comments on openQA

Added by sebchlad almost 6 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-05-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

observation

As a logged in user but without a role assigned in openQA you can not add a comment and get "Forbidden" response

steps to reproduce

  • As a user not in the openQA database log in (this is what okurz wrote)
  • Try to add comment
  • Observe error response

problem

maybe regression

suggestion

  • Add a proper test
  • Try with older version
  • If this is desired behaviour the comment edit window should not be shown at all

Related issues

Is duplicate of openQA Project - action #12118: Normal users can not post any comments anymore at allResolved2016-05-25

History

#1 Updated by okurz almost 6 years ago

  • Is duplicate of action #12118: Normal users can not post any comments anymore at all added

#2 Updated by okurz almost 6 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF