Project

General

Profile

action #120984

assert_script_sudo does not see result

Added by dimstar 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-11-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

According to the screen shots, pidgin is properly removed, zypper returns code 0

All seems fine, yet the test fails

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-desktopapps-message-gnome@64bit fails in
clean_pidgin

Test suite description

Reproducible

Fails since (at least) Build 20221125

Expected result

Last good: 20221124 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dimstar 2 months ago

https://openqa.opensuse.org/tests/2907539#step/zbar/5

This seems to be the same error class: zypper succeeds, openqa die not see the success

#2 Updated by dimstar 2 months ago

Also this one:
https://openqa.opensuse.org/tests/2907539#step/zbar/5

That somewhat hints at https://github.com/os-autoinst/os-autoinst/pull/2191 being responsible for the failures

#3 Updated by dimstar 2 months ago

  • Subject changed from test fails in clean_pidgin to assert_script_sudo does not see result
  • Priority changed from Normal to Urgent

#4 Updated by maritawerner 2 months ago

  • Subject changed from assert_script_sudo does not see result to [desktop] assert_script_sudo does not see result

zcjia or @GraceWang could you please have a look?

#5 Updated by GraceWang 2 months ago

  • Subject changed from [desktop] assert_script_sudo does not see result to assert_script_sudo does not see result

Based on above comments and discussion in eng-testing slack channel on Monday between Dominique and Oliver, this ticket doesn't belong to [Desktop]. So remove the [Desktop] from subject.

#6 Updated by ybonatakis 2 months ago

  • Assignee set to ybonatakis

#7 Updated by ybonatakis 2 months ago

  • Status changed from New to In Progress

The problem is some confusing implementation and how the script_sudo and assert_script_sudo work with the marker. From the os-autoinst-distri-opensuse side the only problem is that the assert_script_sudo uses wrong argument[0]. However the fix requires the necessary bits on os-autoinst. PR in the way

[0] https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/16002

#8 Updated by dimstar 2 months ago

https://openqa.opensuse.org/tests/2913455#step/multi_users_dm/27 fails also on assert_script_sudo, but there we don't have an invalid timeout parameter defined

#9 Updated by ybonatakis 2 months ago

dimstar wrote:

https://openqa.opensuse.org/tests/2913455#step/multi_users_dm/27 fails also on assert_script_sudo, but there we don't have an invalid timeout parameter defined

I will check. give me some time to complete os-autoinst changes

#10 Updated by ybonatakis 2 months ago

https://github.com/os-autoinst/os-autoinst/pull/2223/files submitted but i have problem with the tests for now

#11 Updated by ybonatakis 2 months ago

dimstar wrote:

https://openqa.opensuse.org/tests/2913455#step/multi_users_dm/27 fails also on assert_script_sudo, but there we don't have an invalid timeout parameter defined

http://aquarius.suse.cz/tests/14360 seems ok with the changes on both sides

#12 Updated by ybonatakis 2 months ago

  • Status changed from In Progress to Feedback

#13 Updated by dimstar 2 months ago

  • Status changed from Feedback to Resolved

openQA confirmed in the product: https://openqa.opensuse.org/tests/2917652

Also available in: Atom PDF