Project

General

Profile

action #115583

s390x container workers fail most of the time

Added by dimstar 4 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-08-22
Due date:
% Done:

100%

Estimated time:
Difficulty:
Tags:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-s390x-textmode-server@s390x-zVM-vswitch-l2 fails in
bootloader_s390

The s390x snapshots are mostly blocked by openQA, always failing as early as the s390x bootloader module.

s390linux147 login: xterm: Error 18, errno 1: Operation not permitted
Reason: spawn: open() failed on ptsname

worker openqaworerk1_container103 seems to be the 'most successful' one, followed by _104; _101 and _102 basically never succeed any job

Test suite description

The base test suite is used for job templates defined in YAML documents. It has no settings of its own.

Reproducible

Fails since (at least) Build 20220821

Expected result

Last good: 20220820 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dimstar 4 months ago

From slack #eng-testing

Fabian Vogt
:bugzilla: 28 minutes ago
I did aa-teardown and restarted the affected containers - podman exec at least works again

#2 Updated by maritawerner 3 months ago

  • Tags set to qac

#3 Updated by favogt 3 months ago

  • Status changed from New to Blocked

I did some investigation and filed a product bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1202821

#4 Updated by favogt 3 months ago

BTW: As part of the investigation (on ow1 directly) I installed some packages for debugging: bpftool, systemtap and kernel-default-debuginfo. After this is solved those should be removed and the SLE update debug repo disabled again to save space and time.

#6 Updated by okurz 2 months ago

  • Assignee set to favogt

https://bugzilla.opensuse.org/show_bug.cgi?id=1202821 is marked as RESOLVED FIXED with updates available. ow1 currently seems to have other problems, working on that within #117574 . After that I assume you can continue.

#7 Updated by favogt 2 months ago

Yep, the issue reported in this ticket should be fully addressed. The runc update got published already so I removed the package lock on ow1.

#8 Updated by favogt 2 months ago

  • Status changed from Blocked to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF