Project

General

Profile

Actions

action #115418

closed

Setup ow19+20 to be able to run MM tests size:M

Added by mkittler almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2022-08-17
Due date:
% Done:

100%

Estimated time:

Description

Acceptance criteria

  • AC1: ow19+20 are capable (and configured by adding the "tap" worker class) to run MM tests
  • AC2: GRE tunnels are configured to allow traffic between ow19+20 and existing MM workers ow1+4+7

Suggestions

  • Come up with a scripted solution as touching configuration files manually on now 5 workers (ow19+20 and existing ow1+4+7) would be come quite tedious.
    • Our salt states already show how especially the creation of the GRE tunnel config (/etc/wicked/scripts/gre_tunnel_preup.sh) can be automated using a jinja template. However, we'd preferably stay independent of using the salt machinery here.
    • Writing a simple script that logs into all relevant worker hosts and runs the appropriate commands should be quite simple. Note that when using Perl we could also utilize the Mojolicious template system for generating files. (It can easily be used outside of the context of a web application, see this example.)
  • As a general reference, look into documentation on https://open.qa/docs/#_tap_based_network and our salt states and what has already been configured on ow1+4+7.

Related issues 5 (0 open5 closed)

Related to openQA Infrastructure - action #111473: Get replacements for imagetester and openqaworker1 size:MResolvedmkittler2022-05-23

Actions
Related to openQA Infrastructure - action #115547: openqaworker20 fails to boot, broken hardware size:MResolvedfavogt2022-08-19

Actions
Related to openQA Infrastructure - action #121771: openqaworker20 has no heartbeatResolvedokurz

Actions
Related to openQA Infrastructure - action #121789: MultiMachine tests lose ability to communicateResolvedfavogt2022-12-10

Actions
Related to openQA Project - action #133025: Configure Virtual Interfaces instructions do not work on Leap 15.5 size:MResolveddheidler2023-07-192023-10-31

Actions
Actions #1

Updated by mkittler almost 2 years ago

  • Related to action #111473: Get replacements for imagetester and openqaworker1 size:M added
Actions #2

Updated by livdywan almost 2 years ago

  • Subject changed from Setup ow19+20 to be able to run MM tests to Setup ow19+20 to be able to run MM tests size:M
  • Status changed from New to Workable
Actions #3

Updated by livdywan almost 2 years ago

  • Related to action #115547: openqaworker20 fails to boot, broken hardware size:M added
Actions #4

Updated by mkittler almost 2 years ago

Note that ow20 is currently broken, see #115547. So I'd exclude it for now from this ticket.

Actions #5

Updated by livdywan over 1 year ago

Note: This ticket is not blocked. ow19 can be configured for this.

Actions #6

Updated by dheidler over 1 year ago

  • Assignee set to dheidler
Actions #7

Updated by dheidler over 1 year ago

  • Assignee deleted (dheidler)
Actions #8

Updated by livdywan over 1 year ago

Actions #9

Updated by livdywan over 1 year ago

  • Status changed from Workable to Feedback
  • Assignee set to livdywan

We got as far as verifying that the generated configuration looks sensible. Whether this setup works properly still needs to be confirmed with actual jobs; and no change to work classes was made for now.

Actions #10

Updated by favogt over 1 year ago

cdywan wrote:

We got as far as verifying that the generated configuration looks sensible. Whether this setup works properly still needs to be confirmed with actual jobs; and no change to work classes was made for now.

Did you also configure the GRE tunnel so that all workers can reach each other?

Actions #11

Updated by livdywan over 1 year ago

favogt wrote:

cdywan wrote:

We got as far as verifying that the generated configuration looks sensible. Whether this setup works properly still needs to be confirmed with actual jobs; and no change to work classes was made for now.

Did you also configure the GRE tunnel so that all workers can reach each other?

It's all in the script. If the script does it the answer is yes 😉️

Actions #12

Updated by livdywan over 1 year ago

Seems like @okurz was also working on a script to do the same thing: #119008#note-17

Actions #13

Updated by livdywan over 1 year ago

I'll pick it up again. I had left this on the side due to other infra tickets but it seems fine to continue now.

Actions #14

Updated by favogt over 1 year ago

  • Assignee changed from livdywan to favogt

During setup of ow20 (https://progress.opensuse.org/issues/115547?issue_count=145&issue_position=29&next_issue_id=115418&prev_issue_id=115763#note-41) I tried to copy the config from ow19 but found that the tap/ovs parts were incomplete/broken. After setting it up for ow20 I completed/fixed the ow19 setup as well:

  • eth0 was in public instead of trusted
  • /etc/wicked/scripts/gre_tunnel_preup.sh was broken, I fixed and reran openqa-prepare-mm-setup
  • Added ow19 and ow20 to the gre_tunnel_preup.sh script on ow1, ow4 and ow7

firewalld-policy-* passed: https://openqa.opensuse.org/tests/2929273#dependencies

I'll do some more tests tomorrow and if they look good I'll add the tap class to both.

Actions #15

Updated by favogt over 1 year ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

I'll do some more tests tomorrow and if they look good I'll add the tap class to both.

I did it the other way around: Add the tap class and see what happens. So far no issues observed.

Actions #16

Updated by okurz over 1 year ago

Actions #17

Updated by okurz over 1 year ago

  • Related to action #121789: MultiMachine tests lose ability to communicate added
Actions #18

Updated by okurz 11 months ago

  • Related to action #133025: Configure Virtual Interfaces instructions do not work on Leap 15.5 size:M added
Actions

Also available in: Atom PDF