Project

General

Profile

Actions

action #115196

closed

[qe-core] Prepare for ALP - Schedule Databases testsuite for ALP

Added by szarate almost 2 years ago. Updated 9 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
New test
Target version:
Start date:
2023-05-25
Due date:
2023-05-25
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

Once #115181 is done, we can start small by testing MariaDB, SQLite, PostgreSQL and if it's possible, Redis latest available versions on ALP.

This is work we can also reuse for SLE and openSUSE Leap and TW, so for the better end of it, the tests should be small having a simpler logic than what we normally do.

Notes

Preferably create tickets for individual database systems.

Acceptance criteria

  • AC1: New "Databases" test suite is created for ALP in o3 and osd
  • AC2: Follow-up ticket for SLES is created

Subtasks 3 (0 open3 closed)

action #116057: [qe-core] Test sqlite on ALPRejecteddvenkatachala2023-05-252023-05-25

Actions
action #116446: [qe-core] Test MariaDB on ALPRejectedzluo2023-05-252023-05-25

Actions
action #116602: [qe-core] add Test postgresql on ALP Resolvedzluo2023-05-252023-05-25

Actions

Related issues 2 (2 open0 closed)

Related to openQA Tests - action #117028: [qe-core] Possible improvements for transactional installationsIn Progressdzedro2022-09-22

Actions
Related to openQA Tests - action #160685: [qe-core] End to end testing of Databases using NFS New2024-05-21

Actions
Actions #1

Updated by szarate almost 2 years ago

  • Description updated (diff)
Actions #2

Updated by szarate over 1 year ago

  • Status changed from Workable to Blocked
Actions #3

Updated by szarate over 1 year ago

  • Description updated (diff)
Actions #4

Updated by szarate over 1 year ago

When creating the schedules, put them in schedule/alp, although they are using main.pm

Actions #5

Updated by zluo over 1 year ago

  • Assignee set to zluo

take over and check

Actions #7

Updated by zluo over 1 year ago

Actions #8

Updated by szarate over 1 year ago

  • Sprint changed from QE-Core: August Sprint (Aug 03 - Aug 31) to QE-Core: September Sprint (Aug 31 - Sep 28)
  • Tags changed from qe-core-august-sprint to qe-core-august-sprint, qe-core-september-sprint
Actions #9

Updated by szarate over 1 year ago

  • Status changed from Blocked to Feedback

Zaoliang, Dee... What's left on this ticket? iirc enabling the transactional flavors, right?

Actions #10

Updated by zluo over 1 year ago

szarate wrote:

Zaoliang, Dee... What's left on this ticket? iirc enabling the transactional flavors, right?

the problem is https://github.com/os-autoinst/opensuse-jobgroups/pull/201
What I did in my PR, has been dropped by new job group.
Let's think about this change and make an update??

Actions #11

Updated by zluo over 1 year ago

my try: http://10.162.30.85/tests/5041#step/sqlite3/19

even I add standard repository from ALP, it could work because zypper exit code 5. kvm image is read-only. Non-transactional image is not provided at moment.

Actions #12

Updated by zluo over 1 year ago

  • Status changed from Feedback to Blocked

set it as Blocked for now.

Actions #13

Updated by pdostal over 1 year ago

On 22. 9. 2022, at 11:13, redmine@opensuse.org wrote:

even I add standard repository from ALP, it could work because zypper exit code 5. kvm image is read-only. Non-transactional image is not provided at moment.

And you do use /sbin/transactional-update right?

Actions #14

Updated by zluo over 1 year ago

yes, I tried this but this is not working:

http://10.162.30.85/tests/5049#step/sqlite3

Info about transactional-update:
https://documentation.suse.com/sles/15-SP1/html/SLES-all/cha-transactional-updates.html

Only packages that are part of the snapshot of the root file system can be updated. If packages contain files that are not part of the snapshot, the update could fail or break the system.

Actions #15

Updated by pdostal over 1 year ago

I don’t understand. Can you include some command line output?

Actions #16

Updated by zluo over 1 year ago

pdostal wrote:

I don’t understand. Can you include some command line output?

I tried this:

if(check_var('DISTRI', 'alp')) {
        assert_script_run('transactional-update pkg install sqlite3 expect perl');
     } 
     else {
        zypper_call('install sqlite3 expect perl');
     }

Test died: command 'transactional-update pkg install sqlite3 expect perl' timed out at alp/tests/console/sqlite3.pm line 28.

Actions #17

Updated by pdostal over 1 year ago

Then maybe try this:

if (is_transactional) {
trup_call('pkg install     
check_reboot_changes;
} else {
zypper_call('in firewalld');
}
Actions #18

Updated by zluo over 1 year ago

pdostal wrote:

Then maybe try this:

if (is_transactional) {
trup_call('pkg install     
check_reboot_changes;
} else {
zypper_call('in firewalld');
}

no, this is not working for trup_call or trup_install:
http://10.162.30.85/tests/5054#step/sqlite3/11

Test died: Confirmation dialog not shown at alp/lib/transactional.pm line 177.

Actions #19

Updated by pdostal over 1 year ago

Then it's in my opinion a bug in trup_call which should be fixed.

Actions #20

Updated by szarate over 1 year ago

pdostal wrote:

Then it's in my opinion a bug in trup_call which should be fixed.

indeed, one idea that comes to mind, is to make turp to switch to root console and then switch back to whatever was before... but it's a hack... There's https://progress.opensuse.org/issues/117028

However, for now... if if it's a transactional system, use root-console instead of serial console.

Actions #21

Updated by szarate over 1 year ago

  • Assignee changed from zluo to dvenkatachala

Dee to take a look the workaround, while we come to a definite solution that doesn't require the switch of consoles

Actions #22

Updated by pdostal over 1 year ago

The transactional systems (including ALP) we should use subroutines from lib/transactional.pm.
That basically means that if installing packages on ALP is broken we should fix it in lib/transactional.pm.

Actions #23

Updated by dvenkatachala over 1 year ago

I called the trup_call function in the root console, this seems to be working fine. Verification run after switching to the root console - sqlite3

Actions #24

Updated by szarate over 1 year ago

  • Related to action #117028: [qe-core] Possible improvements for transactional installations added
Actions #25

Updated by szarate over 1 year ago

  • Sprint changed from QE-Core: September Sprint (Aug 31 - Sep 28) to QE-Core: October Sprint (Sep 28 - Oct 26)
Actions #26

Updated by szarate 9 months ago

  • Sprint changed from QE-Core: October Sprint (Sep 28 - Oct 26) to QE-Core: September Sprint 23 (Sep 06 - Oct 04)
Actions #27

Updated by szarate 9 months ago

  • Sprint deleted (QE-Core: September Sprint 23 (Sep 06 - Oct 04))
Actions #28

Updated by szarate 9 months ago

  • Status changed from Blocked to Rejected

Likely, ALP won't have databases on the system (except as workloads, until we get Dolomite/Slate)

Actions #29

Updated by szarate 2 days ago

  • Related to action #160685: [qe-core] End to end testing of Databases using NFS added
Actions

Also available in: Atom PDF