action #11456

Feature 319639: Set hostname in Installer properly

Added by maritawerner about 4 years ago. Updated over 3 years ago.

Status:ResolvedStart date:01/04/2016
Priority:NormalDue date:
Assignee:michalnowak% Done:

0%

Category:New test
Target version:openQA Project - Milestone 3
Difficulty:
Duration:

Description

For details see https://fate.suse.com/319639

First check if the Feature status is "done".

All components of the Installer depend on correctly configured network. Current system hostname is, e.g. used as "the default" when user tries to (re)configure their network in Installer. This configuration checks validity of entered (or default) values and complain when something is wrong. This confuses users as we are expected to provide sane defaults (or nothing).

When Linuxrc is in charge of configuring network (e.g. when installation is started with ifcfg=*=dhcp or when Linuxrc just needs network) the inst-sys then resolves own hostname to the ip address of "first" network interface. It confuses all tools which depends on the resolver's result (e.g. hostname --fqdn)

Proper behavior should be (very simple one out of several possible scenarios):

use a hostname provided by DHCP server (if any) or
return "not resolvable" error

The question is: What to use as a system name (e.g., for command line) in inst-sys? It seems that "installer" or "suse" would just do the job.

For SLE 12 SP1 it was hotfixed on yast side (see https://bugzilla.suse.com/show_bug.cgi?id=946047 for reference)

Purpose of this request is to get proper fix into linuxrc and to drop above hotfix from yast, so affrected pieces are (probably): Linuxrc, installation-images and yast2

History

#1 Updated by RBrownSUSE almost 4 years ago

  • Target version set to 168

#2 Updated by dheidler almost 4 years ago

This isn't the link to the right feature, is it?

#3 Updated by maritawerner almost 4 years ago

  • Description updated (diff)

#4 Updated by maritawerner almost 4 years ago

Link is fixed now!

#5 Updated by okurz almost 4 years ago

  • Target version changed from 168 to Milestone 3

#6 Updated by michalnowak almost 4 years ago

  • Category set to New test
  • Assignee set to michalnowak

#7 Updated by okurz almost 4 years ago

Marita, Michal: Gabriele Mohr from YaST team (gabi in irc://chat.freenode.net/yast) is working on the same feature test, see https://trello.com/c/dwbIW3ke/348-3-sle-12-sp2-p9b-m-automatic-test-case-for-feature-319639-set-hostname-in-installer-properly

I talked to here because she had some questions when I found out and keep track of the issues here but IMHO this is a bigger process issue, i.e. people shouldn't do the same thing at the same time, obviously.

#8 Updated by okurz almost 4 years ago

I saw Gabi already started so I think it makes sense if she starts with it, shows an early implementation proposal as github PR and then Michal or anyone else from "our" team can take over or help. I would not complain that someone is doing "QAs work" ;-)

#9 Updated by michalnowak almost 4 years ago

Thanks for the update, Oliver. I'll help her with the test should she need that.

#10 Updated by gabi2 almost 4 years ago

michalnowak wrote:

Thanks for the update, Oliver. I'll help her with the test should she need that.

I have created https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/1483 containing hostname_inst.pm which shows the general approach we think could be used to implement the tests. It only covers 3 of 4 test cases, the missing is more complicated (hostname has to be set for qemu dhcp server).

#11 Updated by michalnowak over 3 years ago

  • Status changed from New to In Progress

#12 Updated by michalnowak over 3 years ago

Added four yast_hostname* tests based on FATE scenarios to sle-12-SP2-Server-DVD medium of "Acceptance: SLE 12 SP2 1.Server" group. Waiting for them being triggered by new build run (I suppose).

#13 Updated by okurz over 3 years ago

Feature test: PASSED

Ran on osd: https://openqa.suse.de/tests/overview?groupid=25&distri=sle&version=12-SP2&build=2034

example job working: https://openqa.suse.de/tests/502516#step/hostname_inst/5

example job where it failed: https://openqa.suse.de/tests/502215#step/hostname_inst/5 but it works for other architectures for the same test_suite so I assume the problem is the machine settings. Please check.
Also: https://openqa.suse.de/tests/502320 and https://openqa.suse.de/tests/502321

#14 Updated by michalnowak over 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF