Project

General

Profile

action #113198

[qe-core][security] test fails in selinux_setup - bsc#1200649

Added by punkioudi about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
2022-07-04
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

There is an open [bug] for this failure.
Exclude the module from SLES 15-SP4 Maintenance tests.

##Acceptance Criteria

  1. Exclude temporarily selinux_setup.pm from mau-extratests-selinux only in sle 15-SP4 Maintenance tests

Observation

openQA test in scenario sle-15-SP4-Server-DVD-Updates-x86_64-mau-extratests-selinux@64bit fails in
selinux_setup

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. QE Core / Tony Yuan

Reproducible

Fails since (at least) Build 20220629-1

Expected result

Last good: 20220628-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by punkioudi about 1 month ago

  • Tags set to bugbusters, qe-core-coverage
  • Priority changed from Normal to High
  • Target version set to QE-Core: Ready

#2 Updated by szarate about 1 month ago

  • Sprint set to QE-Core: July Sprint (Jul 06 - Aug 03)

#3 Updated by mgrifalconi about 1 month ago

  • Status changed from New to In Progress
  • Assignee set to mgrifalconi

#4 Updated by mgrifalconi about 1 month ago

I feel like the selinux test suite will not work if we only disable "selinux_setup[Summary: Setup environment for selinux tests]", I would disable the entire thing.

#5 Updated by punkioudi about 1 month ago

  • Tags changed from bugbusters, qe-core-coverage to bugbusters
  • Subject changed from [qe-core] test fails in selinux_setup - bsc#1200649 to [qe-core][security] test fails in selinux_setup - bsc#1200649
  • Category deleted (Bugs in existing tests)
  • Assignee deleted (mgrifalconi)
  • Target version deleted (QE-Core: Ready)

#6 Updated by punkioudi about 1 month ago

  • Tags changed from bugbusters to bugbusters, qe-core-coverage
  • Category set to Bugs in existing tests
  • Assignee set to mgrifalconi
  • Target version set to QE-Core: Ready

#8 Updated by rfan1 about 1 month ago

  • Tags changed from bugbusters, qe-core-coverage to bugbusters
  • Category deleted (Bugs in existing tests)
  • Assignee deleted (mgrifalconi)
  • Target version deleted (QE-Core: Ready)

The tests should be security related, since we have it in security group:
http://openqa.suse.de/tests/8753104

pstivanin llzhao,

Can we please check if any new selinux packages released can fix this issue?

BTW, pstivanin, can you please move this test to [Maintenance: Test Repo / Security Maintenance Updates] ?

BR//Richard

#9 Updated by pstivanin about 1 month ago

AFAICS, there was no 'policycoreutils-python-utils' update released recently (or ever).

#10 Updated by pstivanin about 1 month ago

It seems that S:M:24623:274316 is bringing the new python 3.6.15-150300.10.26.1, but policycoreutils-python-utils requires the old one 3.6.15-150300.10.21.1

#12 Updated by pstivanin about 1 month ago

  • Status changed from In Progress to Resolved
  • Assignee set to pstivanin
  • % Done changed from 0 to 100

Also available in: Atom PDF