Project

General

Profile

action #111608

27-consoles-vnc.t 'update framebuffer' test fails on s390x (big-endian) auto_review:"(?s)s390x.*Test died: no candidate needle.*'installation'":retry

Added by AdamWill 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-05-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

When run on s390x, the 'update framebuffer' test fails as it does not get the expected values:

2: 
2:     #   Failed test 'pixel data updated in framebuffer (blue)'
2:     #   at ./27-consoles-vnc.t line 167.
2:     #          got: '37'
2:     #     expected: '41'
2: 
2:     #   Failed test 'pixel data updated in framebuffer (green)'
2:     #   at ./27-consoles-vnc.t line 168.
2:     #          got: '41'
2:     #     expected: '37'
2: 
2:     #   Failed test 'pixel data updated in framebuffer (red)'
2:     #   at ./27-consoles-vnc.t line 169.
2:     #          got: '0'
2:     #     expected: '31'
2:     # Looks like you failed 3 tests of 24.
2: 
2: #   Failed test 'update framebuffer'
2: #   at ./27-consoles-vnc.t line 225.
2: # Looks like you failed 1 test of 21.

History

#1 Updated by okurz 3 months ago

  • Category set to Concrete Bugs
  • Target version set to Ready

#2 Updated by okurz 2 months ago

  • Priority changed from Normal to Low

#3 Updated by mkittler 2 months ago

  • Status changed from New to In Progress

I'll have a look. This shouldn't be too hard to figure out.

#4 Updated by mkittler 2 months ago

  • Status changed from In Progress to Feedback

#5 Updated by mkittler 2 months ago

The PR didn't help, see https://github.com/os-autoinst/os-autoinst/pull/2077#issuecomment-1151349920=. I'm currently out of ideas so I'll check on this low-prio ticket later.

#6 Updated by mkittler about 2 months ago

I've just downloaded the HDD qcow image from https://openqa.opensuse.org/tests/2416488 and booted into it using QEMU on my x86_64 system emulating ppc64. I can reproduce the issue. Maybe I can play around within that setup to find out what's the problem is. It could be an actual bug within the VNC code.

#8 Updated by AdamWill about 2 months ago

Thanks, I will test and confirm the fix.

#9 Updated by AdamWill about 2 months ago

With latest git - ddf414b8d83576d0f5373c15acd70ab2c3ea9fb8 - I still get two fails on s390x:

2: 
2:     #   Failed test 'pixel data updated in framebuffer (blue)'
2:     #   at t/27-consoles-vnc.t line 171.
2:     #          got: '0'
2:     #     expected: '41'
2: 
2:     #   Failed test 'pixel data updated in framebuffer (green)'
2:     #   at t/27-consoles-vnc.t line 172.
2:     #          got: '0'
2:     #     expected: '37'
2:     # Looks like you failed 2 tests of 24.
2: 
2: #   Failed test 'update framebuffer'
2: #   at t/27-consoles-vnc.t line 229.
2: # Looks like you failed 1 test of 21.
2: [20:06:31] t/27-consoles-vnc.t ...................... 

#10 Updated by cdywan about 2 months ago

#12 Updated by okurz about 2 months ago

  • Subject changed from 27-consoles-vnc.t 'update framebuffer' test fails on s390x (big-endian) to 27-consoles-vnc.t 'update framebuffer' test fails on s390x (big-endian) auto_review:"(?s)s390x.*Test died: no candidate needle.*'installation'":retry

#13 Updated by mkittler about 2 months ago

  • Status changed from Feedback to Resolved

Fixed by https://github.com/os-autoinst/os-autoinst/pull/2096 which has already been merged and confirmed by @AdamWill.

Also available in: Atom PDF