action #11160

improve debugging/ log-errror if variable posted to api aren't right.

Added by dmaiocchi almost 4 years ago. Updated 6 months ago.

Status:ResolvedStart date:09/03/2016
Priority:LowDue date:
Assignee:okurz% Done:

0%

Category:Feature requests
Target version:QA - future
Difficulty:
Duration:

History

#1 Updated by dmaiocchi almost 4 years ago

riddle me this

/usr/share/openqa/script/client --params riddle.json jobs post

{
"ARCH" : "ppc64le",
"TEST" : "gnome-ppc",
"PRODUCTDIR" : "/var/lib/openqa/share/tests/sle",
"HDDVERSION" : "SLES-12",
"HDDSIZEGB" : "40",
"ISO_MAXSIZE" : "4700372992",
"DISTRI" : "sle",
"BETA" : "1",
"BETA_SDK" : "1",
"BUILD" : "1225",
"DESKTOP" : "gnome",
"ISO_MAXSIZE" : "4700372992",
"MACHINE" : "64bit",
"VERSION" : "12-SP2",
"FLAVOR" : "Server-DVD",
"GNOME" : 1,
"NUMDISKS" : 1,
"HASLICENSE" : 1,
"BOOT_HDD_IMAGE" : "1",
"HDD_1" : "SLE-12-Server-ppc64le-GM-gnome.qcow2",
"NOAUTOLOGIN" : 1,
"NAME" : "ppctesting",
"NOIMAGES" : 1,
"OFW" : "1",
"NUMDISKS" : 1,
"PACKAGETOINSTALL" : "x3270",
"SHUTDOWN_NEEDS_AUTH" : "1",
"HASLICENSE" : 1,
"VERSION" : "12-SP2",
"QEMU_NO_KVM" : 1,
"QEMU" : "ppc64",
"WALLPAPER" : "/usr/share/wallpapers/SLEdefault/contents/images/1280x1024.jpg",
"QEMUPORT" : "20142",
"QEMUVGA" : "cirrus",
"VNC" : "104"
}

/usr/share/openqa/script/client jobs ... post :

error => "org.freedesktop.DBus.Error.Failed: Can't locate object method \"to_hash\" via package \"0\" (perhaps you forgot to load \"0\"?) at /usr/share/openqa/script/../lib/OpenQA/Scheduler.pm line 119.\n",

#2 Updated by dmaiocchi almost 4 years ago

if you don't find the error, maybe we should improve the catching "debugging" message api, for post jobs to api.

Since , clonejob for ppc doesn't clone the write values for intel that want to reproduce the ppc64

p.s : i have the solution of the riddle ... it costed me time but.

p.s 2: the solution isn't use isotovideo

#3 Updated by RBrownSUSE almost 4 years ago

"ARCH" : "ppc44" should be "ppc64le"

"QEMU" : "ppc64" should be "QEMUCPU" : "POWER8"

#4 Updated by oholecek almost 4 years ago

The problem with this is that you can't check all variables during scheduling. This one is exception when the scheduler couldn't generate any jobs - we're obviously not handling this situation well - but if the problem is somewhere deeper it manifests itself only when job is actually executed and that's already in different universe.

#5 Updated by dmaiocchi almost 4 years ago

@richard : even if you could be right, for the webui isn't correct. the solution is "NAME", that is causing the exception to post the job to webui.

@oholecheck, can we not print the variable that is causing the exception, for posting in the web-ui?

I don't want to check all the variable that might stop the job, but at least that the job to be posted should pass somes check, or at LEAST the variable wrong (for posting the job to webui) should be printed

#6 Updated by okurz about 3 years ago

  • Category set to Feature requests

#7 Updated by michalnowak about 3 years ago

okurz> mnowak: that is the ticket for your yesterday experience: https://progress.opensuse.org/issues/11160

I got this yesterday:

assam:~ # /usr/share/openqa/script/clone_job.pl --verbose --from https://openqa.opensuse.org --host openqa.opensuse.org 334737 
{
   "parents" : {
      "Chained" : [],
      "Parallel" : []
   },
   "id" : 334737,
   "name" : "opensuse-Tumbleweed-NET-x86_64-Build20170115-minimalx-image@64bit",
   "result" : "passed",
   "settings" : {
      "MACHINE" : "64bit",
      "ISO" : "openSUSE-Tumbleweed-NET-x86_64-Snapshot20170115-Media.iso",
      "VERSION" : "Tumbleweed",
      "WORKER_CLASS" : "qemu_x86_64",
      "NETBOOT" : "1",
      "ARCH" : "x86_64",
      "TEST" : "minimalx-image",
      "NAME" : "00334737-opensuse-Tumbleweed-NET-x86_64-Build20170115-minimalx-image@64bit",
      "DESKTOP" : "minimalx",
      "INSTALLONLY" : "1",
      "BUILD" : "20170115",
      "QEMUCPU" : "qemu64",
      "SUSEMIRROR" : "http://openqa.opensuse.org/assets/repo/openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20170115",
      "FLAVOR" : "NET",
      "MIRROR_HTTP" : "http://openqa.opensuse.org/assets/repo/openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20170115",
      "HDDSIZEGB" : "40",
      "DISTRI" : "opensuse",
      "PUBLISH_HDD_1" : "opensuse-Tumbleweed-x86_64-20170115-minimalx@64bit.qcow2",
      "REPO_0" : "openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20170115",
      "BACKEND" : "qemu",
      "VIRTIO_CONSOLE" : "1",
      "QEMU_COMPRESS_QCOW2" : "1",
      "FULLURL" : "1",
      "ISO_MAXSIZE" : "737280000"
   },
   "priority" : 50,
   "group_id" : 1,
   "test" : "minimalx-image",
   "retry_avbl" : 3,
   "group" : "openSUSE Tumbleweed",
   "t_started" : "2017-01-16T04:17:54",
   "children" : {
      "Chained" : [
         334740,
         334741,
         334742,
         334743
      ],
      "Parallel" : []
   },
   "state" : "done",
   "assets" : {
      "repo" : [
         "openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20170115"
      ],
      "iso" : [
         "openSUSE-Tumbleweed-NET-x86_64-Snapshot20170115-Media.iso"
      ],
      "hdd" : [
         "opensuse-Tumbleweed-x86_64-20170115-minimalx@64bit.qcow2"
      ]
   },
   "clone_id" : null,
   "t_finished" : "2017-01-16T04:42:57"
}
downloading
https://openqa.opensuse.org/tests/334737/asset/iso/openSUSE-Tumbleweed-NET-x86_64-Snapshot20170115-Media.iso
to
/var/lib/openqa/factory/iso/openSUSE-Tumbleweed-NET-x86_64-Snapshot20170115-Media.iso
{
   "VIRTIO_CONSOLE" : "1",
   "QEMU_COMPRESS_QCOW2" : "1",
   "ISO_MAXSIZE" : "737280000",
   "FULLURL" : "1",
   "SUSEMIRROR" : "http://openqa.opensuse.org/assets/repo/openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20170115",
   "QEMUCPU" : "qemu64",
   "BUILD" : "20170115",
   "DISTRI" : "opensuse",
   "BACKEND" : "qemu",
   "PUBLISH_HDD_1" : "opensuse-Tumbleweed-x86_64-20170115-minimalx@64bit.qcow2",
   "REPO_0" : "openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20170115",
   "MIRROR_HTTP" : "http://openqa.opensuse.org/assets/repo/openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20170115",
   "FLAVOR" : "NET",
   "HDDSIZEGB" : "40",
   "ARCH" : "x86_64",
   "_GROUP" : "openSUSE Tumbleweed",
   "INSTALLONLY" : "1",
   "TEST" : "minimalx-image",
   "DESKTOP" : "minimalx",
   "MACHINE" : "64bit",
   "VERSION" : "Tumbleweed",
   "ISO" : "openSUSE-Tumbleweed-NET-x86_64-Snapshot20170115-Media.iso",
   "NETBOOT" : "1",
   "WORKER_CLASS" : "qemu_x86_64"
}
Can't use an undefined value as a HASH reference at /usr/share/openqa/script/clone_job.pl line 287.

#8 Updated by okurz almost 3 years ago

  • Priority changed from Normal to Low
  • Target version set to future

#9 Updated by okurz over 1 year ago

  • Target version changed from future to future

#10 Updated by okurz 6 months ago

  • Status changed from New to Resolved
  • Assignee set to okurz

since then we have much better error handling and output

Also available in: Atom PDF