Project

General

Profile

action #111470

Reconsider folding ok results by default and/or uncollapse all on /tests/overview size:M

Added by okurz 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Reconsider folding ok results by default and/or uncollapse all on /tests/overview

Motivation

Seems like we need what we suggested in https://github.com/os-autoinst/openQA/pull/4610#issuecomment-1116118484 which is "can you show all jobs by clicking on the top right double-arrow as well? Like simply the opposite of the 'hide all' functionality" based on feedback in https://suse.slack.com/archives/C02CU8X53RC/p1653309259472379


Related issues

Copied from openQA Project - action #110719: Fold ok clusters by default, unfold if there is any non-ok resultResolved2022-05-06

History

#1 Updated by okurz 3 months ago

  • Copied from action #110719: Fold ok clusters by default, unfold if there is any non-ok result added

#2 Updated by mkittler 3 months ago

  • Assignee set to mkittler

I'll try adding an "Uncollapse all" button.

#3 Updated by mkittler 3 months ago

  • Status changed from New to Feedback

Adding an uncollapse button would be easy: https://github.com/os-autoinst/openQA/pull/4668

#4 Updated by mkittler 2 months ago

  • Status changed from Feedback to Resolved

It works in production, e.g. https://openqa.suse.de/tests/overview?distri=sle&version=15-SP1&build=20220608-1&groupid=412. I haven't seen any further complaints so I suppose the ticket can be resolved.

#5 Updated by AdamWill about 2 months ago

I don't really love this for Fedora's test suites, especially on updates, where we have many small groups of parallel children and aren't really gaining anything by having them collapsed. But I can live with it. However, I would really prefer if "softfailed" was not considered "OK" for this purpose. I think it would be better to only collapse passes. "softfail" means "needs inspection", and you can't inspect something you don't see. I was rather confused why the overview said 4 softfails but I could only see 1 on the build page, until tinita pointed out this was the cause.

#6 Updated by okurz about 2 months ago

  • Status changed from Resolved to Feedback

AdamWill wrote:

I don't really love this for Fedora's test suites, especially on updates, where we have many small groups of parallel children and aren't really gaining anything by having them collapsed.

Could you share some links to such test overviews where you don't like it?

But I can live with it. However, I would really prefer if "softfailed" was not considered "OK" for this purpose. I think it would be better to only collapse passes. "softfail" means "needs inspection", and you can't inspect something you don't see.

I wonder, why does "softfail" mean "needs inspection" to you? We try to stick to the definition from http://open.qa/docs/#concepts which states for softfailed: "At least one known, non-critical issue has been found. That could be that workaround needles are in place, a softfailure has been recorded explicitly via record_soft_failure (from os-autoinst) or a job failure has been ignored explicitly via a job label." Keeping that in mind we defined "passed" and "softfailed" as "ok-results" that do not need immediate work on the test overview page, at least not "review" work in the sense of understanding what is going on because for "softfailed" we assume that people have seen the issue at least once. If they decided to track it elsewhere or not is quite depending on project specific workflows.

#7 Updated by mkittler about 1 month ago

This PR makes the behavior configurable per instance which should be good enough: https://github.com/os-autoinst/openQA/pull/4731

#8 Updated by AdamWill about 1 month ago

Sorry for not replying, I don't seem to be getting emails when other people comment any more. That's odd. I just got one for the PR link.

Example update test: https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=36&build=Update-FEDORA-2022-46e4953e35&groupid=2

#9 Updated by okurz about 1 month ago

  • Due date set to 2022-07-15

@AdamWill Not sure what we should be able to see from the test overview. I would be happy to hear your opinion about #111470#note-6 as well as feedback about https://github.com/os-autoinst/openQA/pull/4731 if that would solve it for you.

#10 Updated by okurz about 1 month ago

  • Subject changed from Reconsider folding ok results by default and/or uncollapse all on /tests/overview to Reconsider folding ok results by default and/or uncollapse all on /tests/overview size:M
  • Description updated (diff)
  • Due date deleted (2022-07-15)
  • Status changed from Feedback to Resolved

PR merged. We are ok with it.

Also available in: Atom PDF