Project

General

Profile

Actions

action #110938

closed

[qe-core] rls rust fail in update_install

Added by mgrifalconi about 2 years ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Test was approved manually, see https://suse.slack.com/archives/C02D16TCP99/p1652262362858569
But we might want to fix the test for future cases.

Processing conflicts -  0
0| 2022-05-10 14:11:30 <3> susetest(15968) [zypp::solver] SATResolver.cc(solving):654 Solverrun finished with an ERROR
0| 2022-05-10 14:11:30 <2> susetest(15968) [zypp::solver] SATResolver.cc(resolvePool):816 SATResolver::resolvePool() done. Ret:0
0| 2022-05-10 14:11:30 <1> susetest(15968) [zypp::solver] Resolver.cc(problems):428 Resolver::problems()
0| 2022-05-10 14:11:30 <1> susetest(15968) [zypp::solver] SATResolver.cc(problems):1287 Encountered problems! Here are the solutions:
0| 2022-05-10 14:11:30 <1> susetest(15968) [zypp::solver] SATResolver.cc(problems):1287 
0| 2022-05-10 14:11:30 <1> susetest(15968) [zypp::solver] SATResolver.cc(problems):1291 Problem 1:
0| 2022-05-10 14:11:30 <1> susetest(15968) [zypp::solver] SATResolver.cc(problems):1292 ====================================
0| 2022-05-10 14:11:30 <1> susetest(15968) [zypp::solver] SATResolver.cc(problems):1296 the to be installed rls-1.54.0-21.6.2.x86_64 requires 'rust1.54', but this requirement cannot be provided
0| 2022-05-10 14:11:30 <1> susetest(15968) [zypp::solver] SATResolver.cc(problems):1297 ------------------------------------
0| 2022-05-10 14:11:30 <1> susetest(15968) [libsolv++] PoolImpl.cc(logSat):131 solver statistics: 0 learned rules, 2 unsolvable, 0 minimization steps
rls no longer exists as its own package, its included in others now ... so it wont install for this update.
Not sure how you can mark this correct as cnflict in the conflict list

openQA test in scenario sle-15-SP3-Server-DVD-Incidents-Install-x86_64-qam-incidentinstall@64bit fails in
update_install

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Incident Installation TEST
MAX_JOB_TIME=9000 due to long texlive update

Reproducible

Fails since (at least) Build :24027:rust (current job)

Expected result

Last good: :24161:php7 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by apappas almost 2 years ago

  • Subject changed from [qe-core] test fails in update_install to [qe-core] rls rust fail in update_install
Actions #3

Updated by slo-gin 3 months ago

This ticket was set to Normal priority but was not updated within the SLO period. Please consider picking up this ticket or just set the ticket to the next lower priority.

Actions #4

Updated by mgrifalconi 3 months ago

  • Status changed from New to Resolved
  • Assignee set to mgrifalconi
Actions

Also available in: Atom PDF