Project

General

Profile

action #110260

o3 logreports - /var/lib/openqa/share/tests/obs/needles is not a git directory size:M

Added by tinita 2 months ago. Updated 27 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-02-03
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

We see the following warnings on o3:

# /var/log/openqa
[2022-04-25T09:17:28.805933Z] [warn] [pid:8752] /var/lib/openqa/share/tests/obs/needles is not a git directory
[2022-04-25T09:45:21.130734Z] [warn] [pid:29759] /var/lib/openqa/share/tests/obs/needles is not a git directory
[2022-04-25T09:51:16.928704Z] [warn] [pid:32010] /var/lib/openqa/share/tests/obs/needles is not a git directory
[2022-04-25T09:59:06.379418Z] [warn] [pid:1890] /var/lib/openqa/share/tests/obs/needles is not a git directory
[2022-04-25T10:05:23.079609Z] [warn] [pid:9221] /var/lib/openqa/share/tests/obs/needles is not a git directory

More context for the last one:

[2022-04-25T10:05:23.021959Z] [info] [pid:9221] Running cmd: git -C /var/lib/openqa/share/tests/obs log --stat --pretty=oneline --abbrev-commit --no-merges dd41ad936f8deb0f38400a26cf2bb6e4ca909e93..4928900e3ff4a75a18bbb5f5e6ddf0ae7992eb5a
[2022-04-25T10:05:23.048900Z] [debug] [pid:9221] b7ff8ae Move ruby tests into a branch specific Makefile
 tests/rspec_webui_tests.pm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
0f78bed Move installation etc. to a Makefile in the branch
 tests/rspec_webui_tests.pm | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)
[2022-04-25T10:05:23.049215Z] [info] [pid:9221] cmd returned 0
[2022-04-25T10:05:23.049622Z] [info] [pid:9221] Running cmd: timeout 20 git -C /var/lib/openqa/share/tests/obs diff --stat dd41ad936f8deb0f38400a26cf2bb6e4ca909e93..4928900e3ff4a75a18bbb5f5e6ddf0ae7992eb5a
[2022-04-25T10:05:23.077203Z] [debug] [pid:9221]  tests/rspec_webui_tests.pm | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)
[2022-04-25T10:05:23.077519Z] [info] [pid:9221] cmd returned 0
[2022-04-25T10:05:23.079609Z] [warn] [pid:9221] /var/lib/openqa/share/tests/obs/needles is not a git directory

Reproduced by: https://openqa.opensuse.org/tests/2315662#investigation (DISTRI=obs)

The needles directory is not a git repo on its own, but just a needles/ subdirectory in the distri repo. (I wonder why we haven't seen this log message before.)

Rollback steps

Acceptance criteria

  • AC1: The case is handled instead of resulting in a warning

Suggestions

  • Confirm that the code already works as intended and the warnings may be pointless
  • Maybe this is a warning that can be ignored or handled

Related issues

Copied from openQA Project - action #105924: o3 logreports - Template was modifiedRejected2022-02-03

Copied to openQA Project - action #110389: o3 logreports - fatal: ambiguous argument: unknown revision or path not in the working tree size:MResolved2022-05-17

History

#1 Updated by tinita 2 months ago

  • Copied from action #105924: o3 logreports - Template was modified added

#2 Updated by tinita 2 months ago

  • Description updated (diff)

#3 Updated by tinita 2 months ago

  • Description updated (diff)

#4 Updated by tinita 2 months ago

  • Description updated (diff)
  • Priority changed from High to Normal

#5 Updated by tinita about 2 months ago

  • Copied to action #110389: o3 logreports - fatal: ambiguous argument: unknown revision or path not in the working tree size:M added

#6 Updated by okurz about 2 months ago

  • Status changed from New to Blocked
  • Assignee set to okurz

#7 Updated by okurz about 2 months ago

  • Tags set to reactive work
  • Status changed from Blocked to New
  • Assignee deleted (okurz)

blockers resolved

#8 Updated by cdywan about 2 months ago

  • Subject changed from o3 logreports - /var/lib/openqa/share/tests/obs/needles is not a git directory to o3 logreports - /var/lib/openqa/share/tests/obs/needles is not a git directory size:M
  • Description updated (diff)
  • Status changed from New to Workable

#9 Updated by kraih about 1 month ago

  • Assignee set to kraih

#10 Updated by kraih 27 days ago

  • Status changed from Workable to In Progress

#11 Updated by kraih 27 days ago

I agree that the warning does look rather pointless. PR opened: https://github.com/os-autoinst/openQA/pull/4680

#12 Updated by kraih 27 days ago

  • Status changed from In Progress to Feedback

#14 Updated by okurz 27 days ago

  • Status changed from Feedback to Resolved

merged https://github.com/os-autoinst/openqa-logwarn/pull/39 which removed the monitoring blocklist entry. With that merged as well I guess we should be good.

Also available in: Atom PDF