Project

General

Profile

action #110049

[qe-core] Samba 4.16: net share -S does not list $username

Added by dimstar 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-04-18
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

Since the upgrade to samba 4.16, the command
net share -S
Seems to no longer output 'bernhard' in the list. The rest looks identical.

We need to identify if this needs adjustments in the test or if this change in sambas behaviour is wrong

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_filesystem@64bit fails in
server

Test suite description

Maintainer: QE Core

Filesystem related tests, for example snapper and btrfs features.

Reproducible

Fails since (at least) Build 20220407

Expected result

Last good: 20220406 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by maritawerner 2 months ago

  • Subject changed from Samba 4.16: net share -S does not list $username to [qe-core] Samba 4.16: net share -S does not list $username

#2 Updated by szarate 2 months ago

  • Sprint set to QE-Core: April Sprint (Apr 13 - May 11)
  • Tags set to bugbusters, outofsprint
  • Target version set to QE-Core: Ready

#3 Updated by ph03nix 2 months ago

  • Status changed from New to In Progress
  • Assignee set to ph03nix

#4 Updated by ph03nix 2 months ago

IMHO this is a test issue:

    validate_script_output "net share -S localhost -U '$username%$password'", qr/$username/;

Expects a share with name bernhard, however only the following shares are present:

tumbleweed:/etc/samba # net share -S localhost -U bernhard%nots3cr3t
profiles
users
groups
print$
IPC$

The last good one is: https://openqa.opensuse.org/tests/2284944#step/server/45 and there indeed bernhard is present.

If I look at the smb.conf on localhost, there I wonder why there was ever bernhard present. IMHO that should not be the case. By default there should be profiles, users, and groups present.

#5 Updated by ph03nix 2 months ago

#6 Updated by ph03nix 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Fixed in the latest test runs: https://openqa.opensuse.org/tests/2314111

Also available in: Atom PDF